summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2021-02-09 11:07:56 -0500
committerMichael Orlitzky <mjo@gentoo.org>2021-02-09 11:08:15 -0500
commitb2e558e9595abb6d0969c2a329897d36b09f4fee (patch)
treef535ad568b29f4eba1334c589729fd749d285f14
parentnet-firewall/ebtables: switch init to checkpath #603268 (diff)
downloadgentoo-b2e558e9595abb6d0969c2a329897d36b09f4fee.tar.gz
gentoo-b2e558e9595abb6d0969c2a329897d36b09f4fee.tar.bz2
gentoo-b2e558e9595abb6d0969c2a329897d36b09f4fee.zip
app-text/diff-pdf: new revision to build against unstable poppler.
Upstream already had a patch for this, easy. Closes: https://bugs.gentoo.org/761835 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--app-text/diff-pdf/diff-pdf-0.4.1-r2.ebuild (renamed from app-text/diff-pdf/diff-pdf-0.4.1-r1.ebuild)9
-rw-r--r--app-text/diff-pdf/files/diff-pdf-0.4.1-no-poppler-cairo-check.patch24
2 files changed, 32 insertions, 1 deletions
diff --git a/app-text/diff-pdf/diff-pdf-0.4.1-r1.ebuild b/app-text/diff-pdf/diff-pdf-0.4.1-r2.ebuild
index f5b10815eafe..992e9b377978 100644
--- a/app-text/diff-pdf/diff-pdf-0.4.1-r1.ebuild
+++ b/app-text/diff-pdf/diff-pdf-0.4.1-r2.ebuild
@@ -4,7 +4,7 @@
# No EAPI=7 support in wxwidgets.eclass.
EAPI=7
-inherit wxwidgets
+inherit autotools wxwidgets
DESCRIPTION="A simple tool for visually comparing two PDF files"
HOMEPAGE="http://vslavik.github.io/diff-pdf/ https://github.com/vslavik/diff-pdf/"
@@ -32,6 +32,13 @@ DEPEND="app-text/poppler[cairo]
x11-libs/wxGTK:3.0-gtk3[X]"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-no-poppler-cairo-check.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
WX_GTK_VER="3.0-gtk3"
setup-wxwidgets
diff --git a/app-text/diff-pdf/files/diff-pdf-0.4.1-no-poppler-cairo-check.patch b/app-text/diff-pdf/files/diff-pdf-0.4.1-no-poppler-cairo-check.patch
new file mode 100644
index 000000000000..ecef020a998a
--- /dev/null
+++ b/app-text/diff-pdf/files/diff-pdf-0.4.1-no-poppler-cairo-check.patch
@@ -0,0 +1,24 @@
+From 00fd9ab8bf435658616f3f25b18d51b0a7ee5769 Mon Sep 17 00:00:00 2001
+From: FX Coudert <fxcoudert@gmail.com>
+Date: Sat, 12 Dec 2020 16:18:59 +0100
+Subject: [PATCH] Remove legacy poppler-cairo dependency (#69)
+
+poppler-glib already depended on it, so this is non-breaking,
+and it is removed in poppler 0.18.1.
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 382e220..2e9b6e5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -41,7 +41,7 @@ AC_LANG(C++)
+ dnl === Library checks ===
+
+ PKG_CHECK_MODULES(POPPLER,
+- [poppler-cairo >= 0.10 poppler-glib >= 0.10 cairo-pdf])
++ [poppler-glib >= 0.10 cairo-pdf])
+
+ AM_OPTIONS_WXCONFIG
+ AM_PATH_WXCONFIG([3.0.0], [wxfound=1], [wxfound=0], [core,base])