summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-09 09:39:17 +0100
committerSam James <sam@gentoo.org>2023-06-09 09:41:54 +0100
commitb34bb321a99d6469e05a4b124b8772969fd2982e (patch)
treeab8b59da7150b217f5b056cbc9b53f114b36b2ae
parentsys-libs/freeipmi: drop 1.6.9, 1.6.10 (diff)
downloadgentoo-b34bb321a99d6469e05a4b124b8772969fd2982e.tar.gz
gentoo-b34bb321a99d6469e05a4b124b8772969fd2982e.tar.bz2
gentoo-b34bb321a99d6469e05a4b124b8772969fd2982e.zip
sys-libs/freeipmi: add 1.6.11
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-libs/freeipmi/Manifest1
-rw-r--r--sys-libs/freeipmi/freeipmi-1.6.11.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/sys-libs/freeipmi/Manifest b/sys-libs/freeipmi/Manifest
index ec6938a0c85e..5572fab3da51 100644
--- a/sys-libs/freeipmi/Manifest
+++ b/sys-libs/freeipmi/Manifest
@@ -1 +1,2 @@
DIST freeipmi-1.6.10.tar.gz 3431062 BLAKE2B e217570d8fcf78ca9d04aad4d5bd46b4120beb21f2dcfb083bc9779a4541856e08ec6e87549651ee3c9b62fe54521585e192c784254dd9482bf9da09935853ae SHA512 90b6b78cdd119c2a1f332f007333aa6df70c6e3de0fd81ab007025392ee7cb7a01ab4a7a174d1f2e760c55d78f21ebbbe9667af661ccdd669e4b54edb1346937
+DIST freeipmi-1.6.11.tar.gz 3429533 BLAKE2B abc803341db4e48fe1a81da1d9cce2e7a808e51f41fb5b18019fa25bec41b443275f737553fe8b7bfd1dd9ad06d08b2097ca9f8e78a431e20d1a0e89d0e8cda6 SHA512 db37bb1ec559f88764ac08491b616d24e49c9a8ba070717e940fea4886d877819064cb00221aac703d0d149dc38e562924e192e992222e18b0e8b548248487a4
diff --git a/sys-libs/freeipmi/freeipmi-1.6.11.ebuild b/sys-libs/freeipmi/freeipmi-1.6.11.ebuild
new file mode 100644
index 000000000000..0494945c26a4
--- /dev/null
+++ b/sys-libs/freeipmi/freeipmi-1.6.11.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_P="${P/_/.}"
+DESCRIPTION="Provides Remote-Console and System Management Software as per IPMI v1.5/2.0"
+HOMEPAGE="https://www.gnu.org/software/freeipmi/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+IUSE="debug doc nagios without-root"
+
+RDEPEND="dev-libs/libgcrypt:="
+DEPEND="
+ ${RDEPEND}
+ virtual/os-headers
+"
+RDEPEND="
+ ${RDEPEND}
+ nagios? (
+ || ( net-analyzer/icinga net-analyzer/nagios )
+ dev-lang/perl
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.10-header-fixes.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable doc)
+ $(usev without-root --with-dont-check-for-root)
+ --disable-static
+ --disable-init-scripts
+ --localstatedir="${EPREFIX}"/var
+ ac_cv_path_CPP_FOR_BUILD="$(tc-getPROG CPP cpp)"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # freeipmi by defaults install _all_ commands to /usr/sbin, but
+ # quite a few can be run remotely as standard user, so move them
+ # in /usr/bin afterwards.
+ dodir /usr/bin
+ local prog
+ for prog in ipmi{detect,ping,power,console}; do
+ mv "${ED}"/usr/{s,}bin/${prog} || die
+
+ # The default install symlinks these commands to add a dash
+ # after the ipmi prefix; we repeat those after move for
+ # consistency.
+ rm "${ED}"/usr/sbin/${prog/ipmi/ipmi-}
+ dosym ${prog} /usr/bin/${prog/ipmi/ipmi-}
+ done
+
+ # Install the nagios plugin in its proper place, if desired
+ if use nagios; then
+ dodir /usr/$(get_libdir)/nagios/plugins
+ mv "${ED}"/usr/share/doc/${PF}/contrib/nagios/nagios_ipmi_sensors.pl \
+ "${ED}"/usr/$(get_libdir)/nagios/plugins/ || die
+ fperms 0755 /usr/$(get_libdir)/nagios/plugins/nagios_ipmi_sensors.pl
+
+ insinto /etc/icinga/conf.d
+ newins "${FILESDIR}"/freeipmi.icinga freeipmi-command.cfg
+ fi
+
+ dodoc AUTHORS ChangeLog* DISCLAIMER* NEWS README* TODO doc/*.txt
+
+ keepdir \
+ /var/cache/ipmiseld \
+ /var/cache/ipmimonitoringsdrcache \
+ /var/lib/freeipmi \
+ /var/log/ipmiconsole
+
+ # starting from version 1.2.0 the two daemons are similar enough
+ newinitd "${FILESDIR}"/bmc-watchdog.initd.4 ipmidetectd
+ newconfd "${FILESDIR}"/ipmidetectd.confd ipmidetectd
+
+ newinitd "${FILESDIR}"/bmc-watchdog.initd.4 bmc-watchdog
+ newconfd "${FILESDIR}"/bmc-watchdog.confd bmc-watchdog
+
+ newinitd "${FILESDIR}"/bmc-watchdog.initd.4 ipmiseld
+ newconfd "${FILESDIR}"/ipmiseld.confd ipmiseld
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}