summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-01 19:58:57 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-01 20:14:54 +0100
commitb4ba553d85cfe4dd19c8d6883e46487009c05afc (patch)
tree5bd23ed5f95f1d7f66b449eab1f466870cc92635
parentdev-python/nest_asyncio: Bump to 1.5.2 (diff)
downloadgentoo-b4ba553d.tar.gz
gentoo-b4ba553d.tar.bz2
gentoo-b4ba553d.zip
dev-python/pkginfo: Bump to 1.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pkginfo/Manifest1
-rw-r--r--dev-python/pkginfo/pkginfo-1.8.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pkginfo/Manifest b/dev-python/pkginfo/Manifest
index bd94cbfa4e78..76702fec59b6 100644
--- a/dev-python/pkginfo/Manifest
+++ b/dev-python/pkginfo/Manifest
@@ -1 +1,2 @@
DIST pkginfo-1.7.1.tar.gz 34280 BLAKE2B ad928cf80423977e5944e3110150afb3e5ae416bf1fd28aec8099c3f25e41956b49e4134cdee5e0621e5bdff44d7161c3b1783b3c6d15555eee86e2e14c29fbb SHA512 5b6374e45e7ccd68f3a28145c2fc350e630e97fcc5e97d46d05c32f0958a51e4713487b809099ddf0a9ab07840f7fb4409438ab7b7a9b0b05e94d292088b2c26
+DIST pkginfo-1.8.1.tar.gz 373496 BLAKE2B 13e21a07f389d5971dc8a999f999c8ef15b84d82f782c29a4912ab5f2a80ed2b812225469d03747e570b8985023c96d2ef05f5449d6b54439dc0efa748a4c5ed SHA512 463dc7d32687ef5105721509f0970efde6da0f00b96f2f6d407a05dc95d5f491838fe5a88b55061df878f0b760d5d825b1f5a65dd1ba1d7f2e1805ed80f72617
diff --git a/dev-python/pkginfo/pkginfo-1.8.1.ebuild b/dev-python/pkginfo/pkginfo-1.8.1.ebuild
new file mode 100644
index 000000000000..090f27714158
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.8.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="https://pypi.org/project/pkginfo/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ # https://bugs.launchpad.net/pkginfo/+bug/1952946
+ pkginfo/tests/test_installed.py::InstalledTests::test_ctor_w_package_no_PKG_INFO
+ )
+
+ epytest
+}