summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-03-02 11:10:01 +0200
committerDavid Seifert <soap@gentoo.org>2017-03-04 16:18:41 +0100
commitb4f8b8fae3ad4f7337ca9b8cb1a7a19a559049b2 (patch)
tree6fc447b8f49b661044e88286aa1a13a808200b39
parentx11-misc/idesk-extras: EAPI bump 5 -> 6 (diff)
downloadgentoo-b4f8b8fae3ad4f7337ca9b8cb1a7a19a559049b2.tar.gz
gentoo-b4f8b8fae3ad4f7337ca9b8cb1a7a19a559049b2.tar.bz2
gentoo-b4f8b8fae3ad4f7337ca9b8cb1a7a19a559049b2.zip
x11-misc/xmountains: EAPI bump 4 -> 6
Package-Manager: Portage-2.3.4, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4098
-rw-r--r--x11-misc/xmountains/xmountains-2.9-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/xmountains/xmountains-2.9-r1.ebuild b/x11-misc/xmountains/xmountains-2.9-r1.ebuild
new file mode 100644
index 000000000000..7bf5d4f892c9
--- /dev/null
+++ b/x11-misc/xmountains/xmountains-2.9-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+MY_P=${P/-/_}
+
+DESCRIPTION="Fractal terrains of snow-capped mountains near water"
+HOMEPAGE="https://spbooth.github.io/xmountains/"
+SRC_URI="http://www.epcc.ed.ac.uk/~spb/${PN}/${MY_P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-misc/xbitmaps"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}
+
+src_prepare() {
+ default
+ # add missing include for strcmp
+ sed -i xmountains.c -e '1a#include <string.h> /* strcmp() */' || die
+ # remove obsolete references to global.*
+ sed -i Makefile.alt README -e 's|global\..||g' || die
+}
+
+src_compile() {
+ emake \
+ -f Makefile.alt \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ newman ${PN}.man ${PN}.1
+ einstalldocs
+}