summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-21 19:54:57 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-22 09:46:52 +0200
commitb6d01c25b2ee41844f5e33dbe3b739af418b0405 (patch)
tree4d1f1181880aa0470b72f682a885061de3278643
parentpackage.mask: remove mask on dev-lang/spark ported on python 3 (diff)
downloadgentoo-b6d01c25b2ee41844f5e33dbe3b739af418b0405.tar.gz
gentoo-b6d01c25b2ee41844f5e33dbe3b739af418b0405.tar.bz2
gentoo-b6d01c25b2ee41844f5e33dbe3b739af418b0405.zip
dev-python/GridDataFormats: add support for tests, enable py3.10
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/GridDataFormats/GridDataFormats-0.5.0.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/dev-python/GridDataFormats/GridDataFormats-0.5.0.ebuild b/dev-python/GridDataFormats/GridDataFormats-0.5.0.ebuild
index dae8fce9e4a9..bae94c0b169b 100644
--- a/dev-python/GridDataFormats/GridDataFormats-0.5.0.ebuild
+++ b/dev-python/GridDataFormats/GridDataFormats-0.5.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
@@ -14,10 +14,19 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="LGPL-3"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="
>=dev-python/numpy-1.0.3[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # This test needs porting to newer numpy
+ sed -i -e 's/test_resample_factor/_&/' \
+ gridData/tests/test_grid.py || die
+
+ distutils-r1_python_prepare_all
+}