summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/GridDataFormats/GridDataFormats-0.5.0.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/dev-python/GridDataFormats/GridDataFormats-0.5.0.ebuild b/dev-python/GridDataFormats/GridDataFormats-0.5.0.ebuild
index dae8fce9e4a9..bae94c0b169b 100644
--- a/dev-python/GridDataFormats/GridDataFormats-0.5.0.ebuild
+++ b/dev-python/GridDataFormats/GridDataFormats-0.5.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
@@ -14,10 +14,19 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="LGPL-3"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="
>=dev-python/numpy-1.0.3[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # This test needs porting to newer numpy
+ sed -i -e 's/test_resample_factor/_&/' \
+ gridData/tests/test_grid.py || die
+
+ distutils-r1_python_prepare_all
+}