summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:11:15 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:30 +0100
commitb7615595b90c9b3028b5df1f600a9d8c1e3ba674 (patch)
tree8e1f91faaab1f6adbf425e047c1c50d621d08e76
parentdev-haskell/yesod-test: add 1.6.14 (diff)
downloadgentoo-b7615595b90c9b3028b5df1f600a9d8c1e3ba674.tar.gz
gentoo-b7615595b90c9b3028b5df1f600a9d8c1e3ba674.tar.bz2
gentoo-b7615595b90c9b3028b5df1f600a9d8c1e3ba674.zip
dev-haskell/yesod: add 1.6.2.1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/yesod/Manifest1
-rw-r--r--dev-haskell/yesod/metadata.xml11
-rw-r--r--dev-haskell/yesod/yesod-1.6.2.1.ebuild40
3 files changed, 45 insertions, 7 deletions
diff --git a/dev-haskell/yesod/Manifest b/dev-haskell/yesod/Manifest
index 6a80a7e27df1..9abeb00e8c87 100644
--- a/dev-haskell/yesod/Manifest
+++ b/dev-haskell/yesod/Manifest
@@ -1 +1,2 @@
+DIST yesod-1.6.2.1.tar.gz 9940 BLAKE2B 7234b550bc54dac8e46deac3d66b0ccb89af184520e9a25d218317dc4c735a7b4fde32ad1ce7325e3d222b551262ea57c36fb0af7cb478489afda499310b28f6 SHA512 ef61044b329b0c6e122bc5ca0203735264f6cb85a4fe728819146b390a8b813a56cad7bd2ef928eb3b3f1ed4618b7f41e856c0f97be1030e50510a14820fd866
DIST yesod-1.6.2.tar.gz 9927 BLAKE2B 551b6a659180536dae72cea4a342f7451eb005cb79bd06cb5af38e41052956c40b93e2368da307ccdcc8bb5e0ea718ae89e7fd858b3273d8823787a333f11da1 SHA512 7c7a3e191ce91ac4070179bdfdae89c60e91c702d9141bb90fcb7095d175727a3f0648221ea151b6e1f5c37a236f55c37aaf963c526e4ced572c19bd6fb0b3a8
diff --git a/dev-haskell/yesod/metadata.xml b/dev-haskell/yesod/metadata.xml
index 7fbdc75a47c4..a9e13b5f8156 100644
--- a/dev-haskell/yesod/metadata.xml
+++ b/dev-haskell/yesod/metadata.xml
@@ -5,11 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- A RESTful web framework with strong compile-time guarantees of correctness. It also affords space efficient code, highly concurrent loads, and portability to many deployment backends (via the wai package), from CGI to stand-alone serving.
-
- Yesod also focuses on developer productivity. Yesod integrates well with tools for all your basic web development (wai, persistent, and shakespeare/hamlet)
-
- The Yesod documentation site &lt;http://www.yesodweb.com/&gt; has much more information, including on the supporting packages mentioned above.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">yesod</remote-id>
+ <remote-id type="github">yesodweb/yesod</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/yesod/yesod-1.6.2.1.ebuild b/dev-haskell/yesod/yesod-1.6.2.1.ebuild
new file mode 100644
index 000000000000..e0052e1cac93
--- /dev/null
+++ b/dev-haskell/yesod/yesod-1.6.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Creation of type-safe, RESTful web applications"
+HOMEPAGE="https://www.yesodweb.com/"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/conduit-1.3:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ dev-haskell/fast-logger:=[profile?]
+ dev-haskell/file-embed:=[profile?]
+ dev-haskell/monad-logger:=[profile?]
+ dev-haskell/shakespeare:=[profile?]
+ dev-haskell/streaming-commons:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-haskell/wai-1.3:=[profile?]
+ >=dev-haskell/wai-extra-1.3:=[profile?]
+ dev-haskell/wai-logger:=[profile?]
+ >=dev-haskell/warp-1.3:=[profile?]
+ >=dev-haskell/yaml-0.8.17:=[profile?]
+ >=dev-haskell/yesod-core-1.6:=[profile?] <dev-haskell/yesod-core-1.7:=[profile?]
+ >=dev-haskell/yesod-form-1.6:=[profile?] <dev-haskell/yesod-form-1.8:=[profile?]
+ >=dev-haskell/yesod-persistent-1.6:=[profile?] <dev-haskell/yesod-persistent-1.7:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"