summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-06-10 14:59:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-06-10 17:30:40 +0200
commitb958840649eda9928e053a81cb09d8564bc74d7a (patch)
treec0f11a422ad12123af066ad0776c6fd205f4bbd1
parentdev-libs/kopeninghours: 21.04.2 version bump (diff)
downloadgentoo-b958840649eda9928e053a81cb09d8564bc74d7a.tar.gz
gentoo-b958840649eda9928e053a81cb09d8564bc74d7a.tar.bz2
gentoo-b958840649eda9928e053a81cb09d8564bc74d7a.zip
dev-libs/kosmindoormap: 21.04.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/kosmindoormap/Manifest1
-rw-r--r--dev-libs/kosmindoormap/kosmindoormap-21.04.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/kosmindoormap/Manifest b/dev-libs/kosmindoormap/Manifest
index ae4cd7076b58..b0e7758d1759 100644
--- a/dev-libs/kosmindoormap/Manifest
+++ b/dev-libs/kosmindoormap/Manifest
@@ -1 +1,2 @@
DIST kosmindoormap-21.04.1.tar.xz 333772 BLAKE2B 0b58671308c5d1c69a921212913d82b32bdef4b86455c4b8b25e23fb0ae75da5886df1a50b1e0c97f9eee327ce58c438fb7bc6905dd24ef03e7f3f59c35c5381 SHA512 6645b4718e864edb6208c8fa0651e0c429cfaa1b46b5d77547e01e2935e3e73302a84eee79183fa9122f6d86fc2074db3b9daa73c97cc8bd13683f1ae94f0766
+DIST kosmindoormap-21.04.2.tar.xz 336984 BLAKE2B 723fbd372e14cc6d731dfccea933ba923fd804b8af4d463fa6eb78fdda8a200d67cf6bd780ad65127d93e44f44c237aa8e84987e7c2df972aa1c2ad731c0f319 SHA512 1bf6513577f0033009deaa506fcddd4407beaf0d8e44e2661b76352e851e154ce3a99e9f1e78c33428f2cdd7f4ba6637dc56882f7dbf97e583140a7972e82449
diff --git a/dev-libs/kosmindoormap/kosmindoormap-21.04.2.ebuild b/dev-libs/kosmindoormap/kosmindoormap-21.04.2.ebuild
new file mode 100644
index 000000000000..a16f08aee91b
--- /dev/null
+++ b/dev-libs/kosmindoormap/kosmindoormap-21.04.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+KDE_GEAR="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.80.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Data Model and Extraction System for Travel Reservation information"
+HOMEPAGE="https://invent.kde.org/libraries/kosmindoormap"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ dev-libs/protobuf:=
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_OsmTools=ON # we have no use for it
+ )
+ ecm_src_configure
+}