summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-01 10:30:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-01 10:35:04 +0200
commitb995f7e71fe425f09969b86f786b50d18dd1dc6c (patch)
tree6c87246e1115d22272a42bcb3225df342496754c
parentdev-python/matplotlib: Bump to 3.4.1 (diff)
downloadgentoo-b995f7e7.tar.gz
gentoo-b995f7e7.tar.bz2
gentoo-b995f7e7.zip
dev-python/vine: Bump to 5.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/vine/Manifest1
-rw-r--r--dev-python/vine/vine-5.0.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/vine/Manifest b/dev-python/vine/Manifest
index 8b41a18f697e..174aa0a8ac9a 100644
--- a/dev-python/vine/Manifest
+++ b/dev-python/vine/Manifest
@@ -1 +1,2 @@
DIST vine-1.3.0.tar.gz 51953 BLAKE2B e58d750dd7a84f4a3abb24156de6ec7ab84a911692587643cabcb0df750d3768e70b14ea134da4a39978782ecc530f4fa08ba0ecb780a7a32fb2d9b506633ef5 SHA512 f7242378ebc9b591b6e0a7b6263514f32cee4b996bc6461313221b9a391dd0dd1d833591d6e9ca72ae003f6ce5c4204856d49bb5e57c69a125072cac25758688
+DIST vine-5.0.0.tar.gz 48758 BLAKE2B 11f90ceb3d3f0b008551db458e18a41b301b797a2109e011154cc3e6063433c3c917b0aa2cfdd0df8b868a3b459c061e6ed97fd23b9fb8cfdf58f5833e17459a SHA512 ff8f4b3f675220772ed0523e468eedbaec4aca793877b984e9a215603d1288cc3cc71dfeb152219d22f98de0ac7e9f9fa0cc35c2424ff36044cfc8f28192c159
diff --git a/dev-python/vine/vine-5.0.0.ebuild b/dev-python/vine/vine-5.0.0.ebuild
new file mode 100644
index 000000000000..515868bc33a1
--- /dev/null
+++ b/dev-python/vine/vine-5.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python Promises"
+HOMEPAGE="https://pypi.org/project/vine/ https://github.com/celery/vine"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ test? (
+ >=dev-python/case-1.3.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest