summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-17 07:25:20 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-17 08:25:34 +0200
commitbb646755410009c49cfdf15199082cadc7d1e5a6 (patch)
tree5bd1413c7963814d119d8ff0fa369276ee04d851
parentdev-python/Nuitka: Bump to 2.2.3 (diff)
downloadgentoo-bb646755410009c49cfdf15199082cadc7d1e5a6.tar.gz
gentoo-bb646755410009c49cfdf15199082cadc7d1e5a6.tar.bz2
gentoo-bb646755410009c49cfdf15199082cadc7d1e5a6.zip
dev-python/botocore: Bump to 1.34.107
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.107.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 89d8c491c489..d77bfe4357c7 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,5 +2,6 @@ DIST botocore-1.34.103.gh.tar.gz 13018336 BLAKE2B 84cef06d1eff09fc9e7d4480bc11be
DIST botocore-1.34.104.gh.tar.gz 13018781 BLAKE2B 1c2cd9988482d2217392572c791b49e415b92229de0c68269dbc58a8ee88f28b1ea2add3557da4dacdd1fb7e72fe47357e18d901188795d6bc5bfc717760e903 SHA512 c66afeb83edc62adfb4d691dcf37c2b76a3cad7b5ea6ec0741129d99ec4a10fa09ed5827b8c6a3224436026ad4fbd7565074e7161921010bb6adcd5f563b30a4
DIST botocore-1.34.105.gh.tar.gz 13020214 BLAKE2B 309c2130756f10d6000c606d2392848869e26ea7bb5bb23c55e60fa9292b263e61be9eedea37f8eed471d9ad70785877797d34135064e49863bc70f1b8a80bac SHA512 ea6f816ccdaa754fa4059c3cab96ac892d1165fa6c988bf3da87227a629989bf006b8b334f0aefa8bb25923f064da478f11561f02a49006274f76fe93fa492d8
DIST botocore-1.34.106.gh.tar.gz 13025091 BLAKE2B 86eff845ca4b2e983b552b2a331cb48b93808355d8c6865170cfab76d13fc6c3caf7335a6131399199536860ca27c886aefca0925c0ebfe8e6ad187fd92b6a24 SHA512 04f74dae3f1de2473d4f832c582538f7a1285fe6020214183bd6fe04e3fb6103346ea28d2f19ef28d6b20c63693876de860d330dd97f23dced35ca0a00da5545
+DIST botocore-1.34.107.gh.tar.gz 13028692 BLAKE2B ab26f39a43d1dad6b2ee7a99878a584601d0368bff65ef1beb0869a1272ce528074633091fd52f34ca839865f83c73b7be238666ccfa8975cbe2e83203f426e6 SHA512 59dcd1a4fe32bd61da81b02a78925cc11e010ccd98445c1073665d3de57a532cbc283dace6cd0772be7c366d5e859b2ea904ee5b197c7e395b75b7b795e13236
DIST botocore-1.34.93.gh.tar.gz 12982900 BLAKE2B 3225279b85101e04da3be11f01ac3f4ca74cf77235fcb8878bc12d7aca61472155c8319329beb54ffe335f9da9023fb3ccce99256f3a31c6588389dfa1746de9 SHA512 505e8c9b3915b1c2da3863b62c85c392a58c12376c3e71493025445b7b672ba320474087b446fda876ffee5d6260909bc1d1442ff6dbfeb49fd6661d3d7840a1
DIST botocore-1.34.98.gh.tar.gz 13008491 BLAKE2B 0b5c368264cc43c162d158b383535183c0fd0065dc6c5edfd3eaaab842d0607b3cc3b99860fa8dc4ef207b5be1457fce9d143723da29e262f30ecc82c5f9ba66 SHA512 39ccb0082ecd6ed6cc7d3f7cea01d39e8d5e92224e3290a66f86ed00562a1d858f75d006af725d2b857ac891f1b366300b7e4c2d24277d942b5a9b9e2cdba431
diff --git a/dev-python/botocore/botocore-1.34.107.ebuild b/dev-python/botocore/botocore-1.34.107.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.107.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}