summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-08 11:55:49 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-08 11:55:49 +0100
commitbbc280302422f9a4e29bc5867894f415d8a3ec0d (patch)
tree3b5ee7facfe3e6a3a6c6dd2a45be5e2a3b55fd72
parentprofiles/arch/powerpc/ppc64/64ul: force dev-libs/efl[lua] (diff)
downloadgentoo-bbc280302422f9a4e29bc5867894f415d8a3ec0d.tar.gz
gentoo-bbc280302422f9a4e29bc5867894f415d8a3ec0d.tar.bz2
gentoo-bbc280302422f9a4e29bc5867894f415d8a3ec0d.zip
sci-chemistry/autodock_vina: Port to EAPI 7
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild29
-rw-r--r--sci-chemistry/autodock_vina/files/autodock_vina-1.1.2-missing-debug-decl.patch11
2 files changed, 27 insertions, 13 deletions
diff --git a/sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild b/sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild
index bbff27f85e2f..59f14e8086c9 100644
--- a/sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild
+++ b/sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild
@@ -1,40 +1,43 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils flag-o-matic versionator
+inherit flag-o-matic
-MY_P="${PN}_$(replace_all_version_separators _)"
+MY_P="${PN}_$(ver_rs 1- _)"
DESCRIPTION="Program for drug discovery, molecular docking and virtual screening"
HOMEPAGE="http://vina.scripps.edu/"
SRC_URI="http://vina.scripps.edu/download/${MY_P}.tgz"
+LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 x86"
-LICENSE="Apache-2.0"
IUSE="debug"
-RDEPEND="dev-libs/boost[threads]"
+RDEPEND="dev-libs/boost:=[threads]"
DEPEND="${RDEPEND}"
S="${WORKDIR}"/${MY_P}/build/linux/release
+PATCHES=(
+ "${FILESDIR}"/${PV}-gentoo.patch
+ "${FILESDIR}"/${P}-boost-filesystem.patch
+ "${FILESDIR}"/${P}-missing-debug-decl.patch
+)
+
src_prepare() {
cd "${WORKDIR}"/${MY_P} || die
- epatch \
- "${FILESDIR}"/${PV}-gentoo.patch \
- "${FILESDIR}"/${P}-boost-filesystem.patch
+ default
}
-src_compile() {
- local c_options
-
+src_configure() {
use debug || c_options="-DNDEBUG"
-
append-cxxflags -DBOOST_FILESYSTEM_VERSION=3
+}
+src_compile() {
emake \
BASE="${EPREFIX}"/usr/ \
GPP="$(tc-getCXX)" \
diff --git a/sci-chemistry/autodock_vina/files/autodock_vina-1.1.2-missing-debug-decl.patch b/sci-chemistry/autodock_vina/files/autodock_vina-1.1.2-missing-debug-decl.patch
new file mode 100644
index 000000000000..c68adb1bff21
--- /dev/null
+++ b/sci-chemistry/autodock_vina/files/autodock_vina-1.1.2-missing-debug-decl.patch
@@ -0,0 +1,11 @@
+--- a/src/lib/quaternion.h
++++ b/src/lib/quaternion.h
+@@ -70,6 +70,8 @@
+ return sqr(q.R_component_1()) + sqr(q.R_component_2()) + sqr(q.R_component_3()) + sqr(q.R_component_4());
+ }
+
++bool quaternion_is_normalized(const qt& q);
++
+ inline void quaternion_normalize(qt& q) {
+ const fl s = quaternion_norm_sqr(q);
+ assert(eq(s, sqr(boost::math::abs(q))));