summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 21:44:28 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 00:07:10 -0500
commitbed22ba14b28518a36cb7c75a82fa37d8c4c2974 (patch)
tree65404d83ffd9bfa7acbc1b5c15bbc6828a5d2c97
parentdev-python/httplib2: 0.12.1 bump (diff)
downloadgentoo-bed22ba14b28518a36cb7c75a82fa37d8c4c2974.tar.gz
gentoo-bed22ba14b28518a36cb7c75a82fa37d8c4c2974.tar.bz2
gentoo-bed22ba14b28518a36cb7c75a82fa37d8c4c2974.zip
dev-python/pydot: 1.4.1 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/pydot/Manifest1
-rw-r--r--dev-python/pydot/pydot-1.4.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pydot/Manifest b/dev-python/pydot/Manifest
index 539437d42ea9..e9cea972d70a 100644
--- a/dev-python/pydot/Manifest
+++ b/dev-python/pydot/Manifest
@@ -1,2 +1,3 @@
DIST pydot-1.0.28.tar.gz 19711 BLAKE2B 73fa2a614de998d4b53065a350768dbf1c0a4aef60edd9d0515ebfc9c685aba09dc42f89849c1eb609e469a4036062d3f0b83b364d89557f73414143c2c78d59 SHA512 54b4d7bfb01bbcae9a4832d1c3321d4f453a93f062ee55b35e3d59bee3f8989f4a544afb56c3d16b22bca8e6ef24b6286ac2688c9045b16906ef625999b35055
DIST pydot-1.2.3.tar.gz 262660 BLAKE2B b5acfc365f7864c2b1fb419e5d4624ebeabef2e969dcf545668062ad46b33de5b5ee65271ac6b0fe0abb48df83f6c24bf3598798eb8879a998c06d91b6a5ac00 SHA512 0527279174bd9d5703131ab6c16365d66e392e27597b5d2d536d43f783a59139913a6dbfa1cc022993f842843f5d79e4e0b2a1435ce3427ebc534ef7b1ef2e9b
+DIST pydot-1.4.1.tar.gz 264987 BLAKE2B 61db2b6dbeab582981bf96054686c927d8d4548ac19a6c197ab1725f92c87e973c2dcd84d4c6c04cb2ca76b8f40814cfee1d5a53e4952065a538fc271e75d2a0 SHA512 b5f16b59908586df61cd415cb1a3e242fb69c39674a82b171862beff1f3727f47cba39bdd806901cb56bc8a6888783a53d112b1b70044e124ea992789d77f938
diff --git a/dev-python/pydot/pydot-1.4.1.ebuild b/dev-python/pydot/pydot-1.4.1.ebuild
new file mode 100644
index 000000000000..b76e59073f32
--- /dev/null
+++ b/dev-python/pydot/pydot-1.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to Graphviz's Dot language"
+HOMEPAGE="https://github.com/erocarrera/pydot https://pypi.org/project/pydot/"
+# pypi releases don't include tests
+SRC_URI="https://github.com/erocarrera/pydot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pyparsing-2.1.4[${PYTHON_USEDEP}]
+ media-gfx/graphviz"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/chardet[${PYTHON_USEDEP}] )"
+
+python_test() {
+ cd test || die
+ "${PYTHON}" pydot_unittest.py || die "Test failed with ${EPYTHON}"
+}