summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-19 07:17:08 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-19 08:02:29 +0200
commitc08bb03132a993ae24150c34d7221231a19b033c (patch)
tree5921bea87d098255b0c8c2ad9b2edacaa481b013
parentdev-python/pyotherside: Bump to 1.6.1 (diff)
downloadgentoo-c08bb03132a993ae24150c34d7221231a19b033c.tar.gz
gentoo-c08bb03132a993ae24150c34d7221231a19b033c.tar.bz2
gentoo-c08bb03132a993ae24150c34d7221231a19b033c.zip
dev-python/griffe: Bump to 0.45.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/griffe/Manifest1
-rw-r--r--dev-python/griffe/griffe-0.45.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/griffe/Manifest b/dev-python/griffe/Manifest
index b11d6630b34c..28297bf04ffc 100644
--- a/dev-python/griffe/Manifest
+++ b/dev-python/griffe/Manifest
@@ -1 +1,2 @@
DIST griffe-0.45.0.gh.tar.gz 230227 BLAKE2B 9baaf356fe766ffa4537329955dd889e464e9d4521c8c3c35121a8b447de3d1ce6f9a5f91c6141af2bf4aeae02fad478155a705069957570036c53a40061e69f SHA512 36eb1bb70aa9b7888506c6ad13b8d4dadbccfce4d63924eddd3d4d90936c8b2588edbac9181fcd6e649a5945213402da63df8eb753c46db3db94e36ae5df4435
+DIST griffe-0.45.1.gh.tar.gz 230569 BLAKE2B 0b0d7aa1de981befa9af63bfbdd14ee28c026cbfe1fbf4c852d5ede23201bc7d38491c732681a217546fbb002b995956576496e4815d0d3c014d66f64f7bae80 SHA512 f5b1e69e53735ee7a51f581611dba4d321ed0128c759f47a32712de4c4a109326478c62f4e91d453acfb3126258fa486a04189991cf9e7c69be3925790598306
diff --git a/dev-python/griffe/griffe-0.45.1.ebuild b/dev-python/griffe/griffe-0.45.1.ebuild
new file mode 100644
index 000000000000..482500b13259
--- /dev/null
+++ b/dev-python/griffe/griffe-0.45.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Signature generator for Python programs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/griffe/
+ https://github.com/mkdocstrings/griffe/
+ https://pypi.org/project/griffe/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/jsonschema-4.17[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # fragile to installed packages
+ # (failed on PySide2 for me)
+ tests/test_stdlib.py::test_fuzzing_on_stdlib
+)