summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2016-03-01 20:49:21 -0600
committerDoug Goldstein <cardoe@gentoo.org>2016-03-01 20:58:38 -0600
commitc0e3b8654d1321d0c52c60eb56968cbede3427e2 (patch)
tree7cdc6ee083fb311f918cdb717d4b12417ffc4517
parentMerge remote-tracking branch 'remotes/Whissi/gentoo-bug-540750' (diff)
downloadgentoo-c0e3b865.tar.gz
gentoo-c0e3b865.tar.bz2
gentoo-c0e3b865.zip
app-emulation/spice-protocol: live ebuilds
Based on the work of Michal Privoznik <miso.privoznik@gmail.com> to provide live ebuilds. Gentoo-Bug: 575652 Package-Manager: portage-2.2.26 Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
-rw-r--r--app-emulation/spice-protocol/spice-protocol-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-emulation/spice-protocol/spice-protocol-9999.ebuild b/app-emulation/spice-protocol/spice-protocol-9999.ebuild
new file mode 100644
index 000000000000..2d21d4c757a4
--- /dev/null
+++ b/app-emulation/spice-protocol/spice-protocol-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-2 autotools
+ EGIT_REPO_URI="git://anongit.freedesktop.org/spice/spice-protocol"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Headers defining the SPICE protocol"
+HOMEPAGE="http://spice-space.org/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ default
+}