summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-12 12:57:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-12 13:18:44 +0200
commitc36aa9d538b33d2cffddb999a62f58668dfe04e6 (patch)
tree87dcf383fc5f6e601dccfd1543c2c1fb47920001
parentdev-python/jupyter_client: Bump to 7.4.2 (diff)
downloadgentoo-c36aa9d538b33d2cffddb999a62f58668dfe04e6.tar.gz
gentoo-c36aa9d538b33d2cffddb999a62f58668dfe04e6.tar.bz2
gentoo-c36aa9d538b33d2cffddb999a62f58668dfe04e6.zip
dev-python/pydyf: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pydyf/Manifest1
-rw-r--r--dev-python/pydyf/pydyf-0.5.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pydyf/Manifest b/dev-python/pydyf/Manifest
index 047dd8aa4298..d865bb623153 100644
--- a/dev-python/pydyf/Manifest
+++ b/dev-python/pydyf/Manifest
@@ -1,2 +1,3 @@
DIST pydyf-0.2.0.gh.tar.gz 14530 BLAKE2B 00c696ea191abe111bf0ef098507f34ebaaaee516dc1afc46a194f3e051171ad1854292f5a3fcf1b559945990647ef8cbb308b3afe0dbc05120f15aa74dc8a63 SHA512 276083d8082c5ccc945144b7d2e3ba29f160d5159aa8d27726079dcc09a44a95d5b0f790874425cb41a00b1c22890b435b756b0bbe14ab43e9ad04a8ae2dad0e
DIST pydyf-0.3.0.gh.tar.gz 14773 BLAKE2B a0d695f73741261e031152bdcfa834b153bc70230996314c5da9234ed388af80d4e2fb24a59a9dabd2e6bbc137696c485ca2a6813361e12d8c74d5a6cc93f60e SHA512 eb4441b0165ab877107ccec41320fdf8b70aebfc9dd1732b6d9fca24d90ba8cb6ac62ce8a90e3b8480ea784e945e240ca00b17648b2b9e17548411f1130b0946
+DIST pydyf-0.5.0.gh.tar.gz 14949 BLAKE2B 07669872135568781b9976bf3fb027784e6a5fee5cddb76c719ca3be7cf20d2ad3416435e1ca9ae2eca097ffdcd8ffc0596e5961e128cb8ce75519de9496e89c SHA512 aeef3b90853b7fd9c157d558185c66887dc227950f087248f53860da43830eb488154b80059ccb7d8f61192111028a129442c185b99f88acf8c9417ebdc873a3
diff --git a/dev-python/pydyf/pydyf-0.5.0.ebuild b/dev-python/pydyf/pydyf-0.5.0.ebuild
new file mode 100644
index 000000000000..31a390ab008f
--- /dev/null
+++ b/dev-python/pydyf/pydyf-0.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A low-level PDF generator"
+HOMEPAGE="
+ https://pypi.org/project/pydyf/
+ https://github.com/CourtBouillon/pydyf/
+"
+SRC_URI="
+ https://github.com/CourtBouillon/pydyf/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ app-text/ghostscript-gpl
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest