summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-12-26 18:41:22 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-12-26 18:41:22 +0700
commitc38677553fa0695d0d666f30c8c3925c08fd0856 (patch)
tree15ef43225a7ab9f9c50ee1c0d0e36b4e180778cb
parentapp-text/crqt-ng: bump to 1.0.12 (diff)
downloadgentoo-c38677553fa0695d0d666f30c8c3925c08fd0856.tar.gz
gentoo-c38677553fa0695d0d666f30c8c3925c08fd0856.tar.bz2
gentoo-c38677553fa0695d0d666f30c8c3925c08fd0856.zip
app-text/pdfarranger: bump to 1.10.1
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
-rw-r--r--app-text/pdfarranger/Manifest1
-rw-r--r--app-text/pdfarranger/pdfarranger-1.10.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-text/pdfarranger/Manifest b/app-text/pdfarranger/Manifest
index 7fec608810bf..31578a31bc78 100644
--- a/app-text/pdfarranger/Manifest
+++ b/app-text/pdfarranger/Manifest
@@ -1,2 +1,3 @@
DIST pdfarranger-1.10.0.tar.gz 303125 BLAKE2B 126b47dfdabbe6d75331788dd891e1d8136a70b98e70601e19fd47fc7e3d81c350eb1fc8866a3a09db88b2b760ef964e7a01cf233464440c81a6dc5462101592 SHA512 92aa53a402d2f4c82a7f99f2acc1c328f71ad18835e524588e0f011f3ba8b074bf425ed881bb5f9ce3020833ce37cc3c301fd90b8931b44f909c8647bc1b09af
+DIST pdfarranger-1.10.1.tar.gz 304298 BLAKE2B 9762864072d4d75cf7e4a65f9ec9db040eef53ee97b2867340bc427d350f4b9b9fbc321520bf2e47d1c2ab2c866c8ceaf56b9806378bcdff4897ebc7f6c1e2ee SHA512 a0bebb569570656217e4f9432c0a3fbdb7f441b7ee04dc82f31e449befec19a1fa1045ef7ce95dc75e9feb14fad9a0265307efdf221c8a727091c05348554427
DIST pdfarranger-1.9.2.tar.gz 280531 BLAKE2B 6a7a8e73e701fe9bbb5bd1f94411003dfb16966ad28522820a27e7ab554b3c2679eec3f4a08332bd58dc1c1cafd620e1daef2f39cb0f6dc5589d7bd5eb293650 SHA512 c22cc753e2606d90913970ce57462b4aca7c41fa6a9b6ece76b618800cad12bce808aba4a6fba2ef9698fda209e11799f30d091a88c9beb2e80a09ac7df51cb8
diff --git a/app-text/pdfarranger/pdfarranger-1.10.1.ebuild b/app-text/pdfarranger/pdfarranger-1.10.1.ebuild
new file mode 100644
index 000000000000..3d021e097334
--- /dev/null
+++ b/app-text/pdfarranger/pdfarranger-1.10.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1 optfeature xdg desktop
+
+DESCRIPTION="Merge or split pdfs; rearrange, rotate, crop pages"
+HOMEPAGE="https://github.com/jeromerobert/pdfarranger"
+SRC_URI="https://github.com/jeromerobert/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/poppler[introspection,cairo]
+ >=dev-python/pikepdf-6.0.0[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ dev-util/intltool
+"
+
+src_install() {
+ distutils-r1_src_install
+ for x in 16 32 48 256 scalable
+ do doicon -s ${x} data/icons/hicolor/${x}*/*
+ done
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "image file import" media-gfx/img2pdf
+}