summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-08-18 14:34:35 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-08-18 14:34:47 +0200
commitc413f7b5998eccfd1ef96fcb9f26d18be6ae5166 (patch)
tree2efeb114a4112d21a354811b2c8e939fe3615679
parentdev-db/mysql: using SSL is mandatory (diff)
downloadgentoo-c413f7b5.tar.gz
gentoo-c413f7b5.tar.bz2
gentoo-c413f7b5.zip
dev-db/mysql-connector-c: Using SSL is mandatory
Closes: https://bugs.gentoo.org/692390 Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--dev-db/mysql-connector-c/mysql-connector-c-8.0.17-r1.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-db/mysql-connector-c/mysql-connector-c-8.0.17-r1.ebuild b/dev-db/mysql-connector-c/mysql-connector-c-8.0.17-r1.ebuild
index 7e8007d8e350..2ed708a01498 100644
--- a/dev-db/mysql-connector-c/mysql-connector-c-8.0.17-r1.ebuild
+++ b/dev-db/mysql-connector-c/mysql-connector-c-8.0.17-r1.ebuild
@@ -16,15 +16,13 @@ SRC_URI="https://dev.mysql.com/get/Downloads/MySQL-8.0/mysql-boost-${PV}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
SLOT="0/21"
-IUSE="ldap libressl +ssl static-libs"
+IUSE="ldap libressl static-libs"
RDEPEND="
sys-libs/zlib:=[${MULTILIB_USEDEP}]
ldap? ( dev-libs/cyrus-sasl:=[${MULTILIB_USEDEP}] )
- ssl? (
- libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
- !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
- )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+ !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}"
@@ -74,7 +72,7 @@ multilib_src_configure() {
-DENABLED_LOCAL_INFILE=ON
-DMYSQL_UNIX_ADDR="${EPREFIX}/run/mysqld/mysqld.sock"
-DWITH_ZLIB=system
- -DWITH_SSL=$(usex ssl system wolfssl)
+ -DWITH_SSL=system
-DLIBMYSQL_OS_OUTPUT_NAME=mysqlclient
-DSHARED_LIB_PATCH_VERSION="0"
-DCMAKE_POSITION_INDEPENDENT_CODE=ON