summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-02 10:36:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-02 10:36:02 +0300
commitc63c449a52422646c65621870132774ff5c76e96 (patch)
treede4230299271b1e3e012ffd9f4b71f6000b5eaa7
parentdev-python/boto3: add 1.21.32 (diff)
downloadgentoo-c63c449a.tar.gz
gentoo-c63c449a.tar.bz2
gentoo-c63c449a.zip
app-admin/awscli: add 1.22.87
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.87.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 073e3f2aafe0..86733fdc3ad7 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -8,3 +8,4 @@ DIST awscli-1.22.83.tar.gz 2182511 BLAKE2B 45e4868e83d130bee6c5a7cb59792d4d66e76
DIST awscli-1.22.84.tar.gz 2182437 BLAKE2B 0b61b6d96da302c95c83bdeedfa14abbcacb1cb3f1a320faa8ca2ee275e43407c0c109c73b7e39879002a920a100a9808fd74582b0620b97534a8eb0deef54a2 SHA512 14054f90c0d4e000869bd6313f61241a736474faf79b8e5768f5e0aadf7230fc6c8441f5c332a1ee4dc22e0023416713d89cde96a4fff4d83ab6826748aaff53
DIST awscli-1.22.85.tar.gz 2183008 BLAKE2B c1fe5dd82331a3b1618d34d739803058c7422087b64959bbccdc0408852ae2f0d5b9a423925176468131befeba25cb035b73e6264e3fb17e5237c407b7e7b342 SHA512 fe767ecddf2979af0d817bd4276737c5372293c27ccec1844e54c2a0f46fc061fceb6cccafc5ef47f17f65d5b77d9ac4189e17e077736c4ad5dd72ecef4b556c
DIST awscli-1.22.86.tar.gz 2184477 BLAKE2B fee34978cef17a0b4f51a9a110836882e11641914f7b2569dc2ce35be705abab16eda68a5706fa8c2bf24ee1c018c97d785296cec31c52aeb5bdf40511475fb9 SHA512 640de79a71459f3532c1d03ce6708a279e3a56e6f13dc3f72d73ced6888d8e30abe02806f6bee1ed04d7d909a667805daeeffaea9829e97b0f1447330d2d0a56
+DIST awscli-1.22.87.tar.gz 2185493 BLAKE2B 5d274e0c9483b22e664ad6de8710c04cc99f854b7c1efdac6dd4164deab47dc55d35520b34b276f8b4de1ee8b1ed10205b1806a31fc776d17b289a5e29277016 SHA512 c117fb8f89680836206f678637fb480ffd06db2225533bff75686eb8c1bd6e450297adb11863247441eeed67744b13930c0f62afce1dd12527d06d4e2eb58a4b
diff --git a/app-admin/awscli/awscli-1.22.87.ebuild b/app-admin/awscli/awscli-1.22.87.ebuild
new file mode 100644
index 000000000000..2040c8cb81d2
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.87.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# awscli 1.22.55 → botocore 1.24.0
+# so botocore is x.(y+2).(z-55)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 55))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}