summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-30 05:16:27 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-30 06:26:53 +0200
commitcba004763218b4670f8222216eb69b93afa6323d (patch)
treef1169da6796a2f0a09380ab9ab202f839d7e86d8
parentdev-python/boto3: Bump to 1.24.20 (diff)
downloadgentoo-cba00476.tar.gz
gentoo-cba00476.tar.bz2
gentoo-cba00476.zip
app-admin/awscli: Bump to 1.25.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.20.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 288b37b8f120..ad71f0fb26a6 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -6,4 +6,5 @@ DIST aws-cli-1.25.16.gh.tar.gz 2225519 BLAKE2B 5800f49afe526f29b76f74078431235ab
DIST aws-cli-1.25.17.gh.tar.gz 2226115 BLAKE2B d07a9c7a8e13019fd728489d27465497ba31f53087ef09e5f816792267bcb58158fa0a7f71fc499d3e343b5b3a0da45cc3632f8c69345b8cd93ebc735f645672 SHA512 1a7f90e28d6702f9e73fe3a93e0d91e2c4ea3d93574f21a3ecde1148445fe6b5f98f217e2e61a1cbba50a07590f0ab0abd00390fb04cbb3db74dfff698224997
DIST aws-cli-1.25.18.gh.tar.gz 2226354 BLAKE2B 5dafc484fcb592bef9e1aa18ff21897bc93c2eda049e5dff64d706fc492c5778ccb818c4368b95ee7f326ad47ee59b7b230875d1ef6e63ed7997e1e761228fd9 SHA512 40a5f0d35956d8fadc8950e0498e9254126914172a26b092ad6cb874f32e9f36a790295687da30d3e9bc41e41672d1e1424ba91051d4e32c46e44ef89601b289
DIST aws-cli-1.25.19.gh.tar.gz 2227148 BLAKE2B a39de70c887b6e036303cdfb9fa435674cd5beb2482c1c71efbdfd675addef72772e538c11850b93be9430d12ce5a7d3293f18bec1a3bd6fd9b4d0c675b7d307 SHA512 430cbc322a26031211fbdb8a9ec4ee810d50b78a80d50b5e8fa254f22fd5131b3b5fc791db10d27d0b85ccb82b4a2a74dac4f1a1f14299262668743417532ec0
+DIST aws-cli-1.25.20.gh.tar.gz 2227422 BLAKE2B 7dfeb6266578fc61a4fa54f39bbaaabcc8c53fc133f1993669a3cda0398fa67a6e54f122b6a103474a0b6a31c7a259237cf4a759995eab727d8f103a8649163a SHA512 0179487b9dbc9864eeb066e9f4f30c67b17dec589c5860b476cbc7798d1b163080d7d3caeae18367afdd89d299f508bfbbb2150d4795aaa85efdeb5b61030663
DIST aws-cli-1.25.7.gh.tar.gz 2223153 BLAKE2B fcadda94fd721135f94b1538c4b27e41108064f6fd32f324d5436138e3d1b0ffcab53fcc545b01c461365d55c4bfa2a05d90e94c875c929a3227efae76452415 SHA512 194adacab0df87d8e4f0cdc71bb956bef6dc8b2de2e7e4416c9c079ff2b7c2bce7584ac1049428d0bcb134368b39c37c04bc5e6a8fc7540c44c64f3934ccaf21
diff --git a/app-admin/awscli/awscli-1.25.20.ebuild b/app-admin/awscli/awscli-1.25.20.ebuild
new file mode 100644
index 000000000000..9f176fa05cc8
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.20.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}