summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2018-02-01 17:35:03 -0500
committerMike Frysinger <vapier@gentoo.org>2018-02-01 17:35:03 -0500
commitcd534eb17c94864a155a6e80b44f8b42ca90480b (patch)
tree2ea224ffd70c8de23d69bd7c4758adfe8ff6b18c
parentsys-apps/iproute2: mark 4.14.1-r2 alpha/arm64/m68k/s390/sh stable #639536 (diff)
downloadgentoo-cd534eb17c94864a155a6e80b44f8b42ca90480b.tar.gz
gentoo-cd534eb17c94864a155a6e80b44f8b42ca90480b.tar.bz2
gentoo-cd534eb17c94864a155a6e80b44f8b42ca90480b.zip
sys-apps/iproute2: make libelf usage optional
This dep is only needed to load eBPF filters out of ELFs compiled (usually) by LLVM's eBPF backend. There's no need to make this a hard dep on everyone's system.
-rw-r--r--sys-apps/iproute2/iproute2-4.15.0.ebuild7
-rw-r--r--sys-apps/iproute2/metadata.xml1
2 files changed, 5 insertions, 3 deletions
diff --git a/sys-apps/iproute2/iproute2-4.15.0.ebuild b/sys-apps/iproute2/iproute2-4.15.0.ebuild
index f38e3db1ff8f..15efa9acf6c9 100644
--- a/sys-apps/iproute2/iproute2-4.15.0.ebuild
+++ b/sys-apps/iproute2/iproute2-4.15.0.ebuild
@@ -18,12 +18,13 @@ HOMEPAGE="https://wiki.linuxfoundation.org/networking/iproute2"
LICENSE="GPL-2"
SLOT="0"
-IUSE="atm berkdb +iptables ipv6 minimal selinux"
+IUSE="atm berkdb elf +iptables ipv6 minimal selinux"
# We could make libmnl optional, but it's tiny, so eh
RDEPEND="
!net-misc/arpd
- !minimal? ( net-libs/libmnl virtual/libelf )
+ !minimal? ( net-libs/libmnl )
+ elf? ( virtual/libelf )
iptables? ( >=net-firewall/iptables-1.4.20:= )
berkdb? ( sys-libs/db:= )
atm? ( net-dialup/linux-atm )
@@ -101,7 +102,7 @@ src_configure() {
TC_CONFIG_IPSET := y
HAVE_BERKELEY_DB := $(usex berkdb y n)
HAVE_MNL := $(usex minimal n y)
- HAVE_ELF := $(usex minimal n y)
+ HAVE_ELF := $(usex elf y n)
HAVE_SELINUX := $(usex selinux y n)
IP_CONFIG_SETNS := ${setns}
# Use correct iptables dir, #144265 #293709
diff --git a/sys-apps/iproute2/metadata.xml b/sys-apps/iproute2/metadata.xml
index 2605d5fd7ce0..ad652efcf7e4 100644
--- a/sys-apps/iproute2/metadata.xml
+++ b/sys-apps/iproute2/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="berkdb">build programs that use berkdb (just arpd)</flag>
+ <flag name="elf">support loading eBPF programs from ELFs (e.g. LLVM's eBPF backend)</flag>
<flag name="iptables">include support for iptables filtering</flag>
<flag name="minimal">only install ip and tc programs, without eBPF support</flag>
</use>