summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 14:52:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:58:33 +0200
commitcf64eac86ab41ef2523defcacd4207c0fccb94e9 (patch)
treed6558686fb945c6fc436637eb00e2c2c0cf34e5b
parentdev-util/rosinstall_generator: Remove old (diff)
downloadgentoo-cf64eac86ab41ef2523defcacd4207c0fccb94e9.tar.gz
gentoo-cf64eac86ab41ef2523defcacd4207c0fccb94e9.tar.bz2
gentoo-cf64eac86ab41ef2523defcacd4207c0fccb94e9.zip
dev-ros/tf: stop using yaml.load
Fixes tests Closes: https://bugs.gentoo.org/623656 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/tf/files/yaml.patch13
-rw-r--r--dev-ros/tf/tf-1.13.2-r1.ebuild (renamed from dev-ros/tf/tf-1.13.2.ebuild)1
-rw-r--r--dev-ros/tf/tf-9999.ebuild1
3 files changed, 15 insertions, 0 deletions
diff --git a/dev-ros/tf/files/yaml.patch b/dev-ros/tf/files/yaml.patch
new file mode 100644
index 000000000000..344ef80417ae
--- /dev/null
+++ b/dev-ros/tf/files/yaml.patch
@@ -0,0 +1,13 @@
+Index: tf/src/tf/listener.py
+===================================================================
+--- tf.orig/src/tf/listener.py
++++ tf/src/tf/listener.py
+@@ -94,7 +94,7 @@ class Transformer(object):
+
+ def getFrameStrings(self):
+ """ Not a recommended API, only here for backwards compatibility """
+- data = yaml.load(self._buffer.all_frames_as_yaml()) or {}
++ data = yaml.safe_load(self._buffer.all_frames_as_yaml()) or {}
+ return [p for p, _ in data.items()]
+
+ def getLatestCommonTime(self, source_frame, dest_frame):
diff --git a/dev-ros/tf/tf-1.13.2.ebuild b/dev-ros/tf/tf-1.13.2-r1.ebuild
index 6f018ff01c10..360303d8a915 100644
--- a/dev-ros/tf/tf-1.13.2.ebuild
+++ b/dev-ros/tf/tf-1.13.2-r1.ebuild
@@ -37,3 +37,4 @@ DEPEND="${RDEPEND}
dev-cpp/gtest
$(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)"
+PATCHES=( "${FILESDIR}/yaml.patch" )
diff --git a/dev-ros/tf/tf-9999.ebuild b/dev-ros/tf/tf-9999.ebuild
index 6f018ff01c10..360303d8a915 100644
--- a/dev-ros/tf/tf-9999.ebuild
+++ b/dev-ros/tf/tf-9999.ebuild
@@ -37,3 +37,4 @@ DEPEND="${RDEPEND}
dev-cpp/gtest
$(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)"
+PATCHES=( "${FILESDIR}/yaml.patch" )