summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-14 04:16:13 +0000
committerSam James <sam@gentoo.org>2024-03-14 04:49:31 +0000
commitd123620a304ed68d4e07d74d1a38c5267dbdc8b1 (patch)
tree9b673643af57d3c7b6c8774bdafe9511fce6d1f3
parentx11-terms/kitty: workaround simde issue with -mxop (diff)
downloadgentoo-d123620a304ed68d4e07d74d1a38c5267dbdc8b1.tar.gz
gentoo-d123620a304ed68d4e07d74d1a38c5267dbdc8b1.tar.bz2
gentoo-d123620a304ed68d4e07d74d1a38c5267dbdc8b1.zip
dev-python/pyasyncore: new package, add 1.0.4
Bug: https://bugs.gentoo.org/909998 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pyasyncore/Manifest1
-rw-r--r--dev-python/pyasyncore/metadata.xml13
-rw-r--r--dev-python/pyasyncore/pyasyncore-1.0.4.ebuild24
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyasyncore/Manifest b/dev-python/pyasyncore/Manifest
new file mode 100644
index 000000000000..8b5051785e12
--- /dev/null
+++ b/dev-python/pyasyncore/Manifest
@@ -0,0 +1 @@
+DIST pyasyncore-1.0.4.tar.gz 15339 BLAKE2B 1cc689c94dc7fe4f4c75a78cf58a0afabbe48f01b8c1511f9500b93b64b862dc1c7cc653e17a49786af9360441fcb45be03fa38c72c2e89ec05385fd8bfc648a SHA512 43746fca009f7acc5f05506c7d54e71ee74a76a112c3689aa98ab714f0452d1ed1196836bf52585bbbced2d64c1d4ccd86f8f5c2d2c5537fdc397e29d0d87008
diff --git a/dev-python/pyasyncore/metadata.xml b/dev-python/pyasyncore/metadata.xml
new file mode 100644
index 000000000000..062106caae26
--- /dev/null
+++ b/dev-python/pyasyncore/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pyasyncore</remote-id>
+ <remote-id type="github">simonrob/pyasyncore</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyasyncore/pyasyncore-1.0.4.ebuild b/dev-python/pyasyncore/pyasyncore-1.0.4.ebuild
new file mode 100644
index 000000000000..e019b13f2aea
--- /dev/null
+++ b/dev-python/pyasyncore/pyasyncore-1.0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_12 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Make asyncore available for Python 3.12 onwards"
+HOMEPAGE="
+ https://github.com/simonrob/pyasyncore
+ https://pypi.org/project/pyasyncore/
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+python_test() {
+ # Can't use d_e_t unittest (bug #926964)
+ eunittest tests
+}