summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-07 03:51:26 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-07 05:14:55 +0200
commitd1705ca8fa228b2d09a8ef476b53a6b1c9389ba6 (patch)
treeb14daf0638e7c581719f81704b07381c3d16e550
parentapp-admin/awscli: Bump to 1.29.0 (diff)
downloadgentoo-d1705ca8fa228b2d09a8ef476b53a6b1c9389ba6.tar.gz
gentoo-d1705ca8fa228b2d09a8ef476b53a6b1c9389ba6.tar.bz2
gentoo-d1705ca8fa228b2d09a8ef476b53a6b1c9389ba6.zip
dev-python/path: Bump to 16.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/path/Manifest1
-rw-r--r--dev-python/path/path-16.7.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/path/Manifest b/dev-python/path/Manifest
index ac041f593be3..24b66b4c66f7 100644
--- a/dev-python/path/Manifest
+++ b/dev-python/path/Manifest
@@ -1 +1,2 @@
DIST path-16.6.0.tar.gz 49670 BLAKE2B 16da36676acb4e4c45c364a09c1d031f4cfc6bdabc08426bc5a8945c4b3594a7dd849f880f76dbfaba4dd2282eee00edbc0f9c7c4ed4774750e023c6a03b3939 SHA512 f1ec159c6b755f98eef90e1aac4337fb84fd9f739beddf34205c5faf9e959863baa52d237899bd33fe8f365a2666af6999c2e9388be310a6acae16b4952df022
+DIST path-16.7.1.tar.gz 48974 BLAKE2B a03eebbb391cf17033adce4d6b258217546e3b7494200a8ea97f756512177f1c7d7ea8155420e167cefe79b566a4240eec98d17b160478f9cb06d3fd839c28f2 SHA512 7d660373046845a5882a316051c350558527d6d8a5cd11735d38214f986c8e096f72b45f87cfec41bf6171e7845287a42e6e45535f87a01b46670eccd4013dbf
diff --git a/dev-python/path/path-16.7.1.ebuild b/dev-python/path/path-16.7.1.ebuild
new file mode 100644
index 000000000000..6cd8ba8201ed
--- /dev/null
+++ b/dev-python/path/path-16.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="
+ https://github.com/jaraco/path/
+ https://pypi.org/project/path/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+)