summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-03-19 23:39:16 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-19 23:39:16 +0100
commitd3e980dfc07df8feaa8a2b40e9570f1eee07e2fe (patch)
tree6e7a3da4a38cfbea41c9b4c31893f882abfcd6ba
parentx11-drivers/xf86-input-joystick: Port to EAPI 7 (diff)
downloadgentoo-d3e980dfc07df8feaa8a2b40e9570f1eee07e2fe.tar.gz
gentoo-d3e980dfc07df8feaa8a2b40e9570f1eee07e2fe.tar.bz2
gentoo-d3e980dfc07df8feaa8a2b40e9570f1eee07e2fe.zip
x11-drivers/xf86-input-vmmouse: Port to EAPI 7
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild19
-rw-r--r--x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-9999.ebuild19
2 files changed, 17 insertions, 21 deletions
diff --git a/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild
index 5729c0d5e63d..2e0a13029688 100644
--- a/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild
+++ b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-13.1.0-r1.ebuild
@@ -1,30 +1,29 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit udev xorg-2
+inherit udev xorg-3
DESCRIPTION="VMWare mouse input driver"
-IUSE=""
+
KEYWORDS="amd64 x86"
RDEPEND=""
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
--with-hal-bin-dir=/punt
--with-hal-callouts-dir=/punt
--with-hal-fdi-dir=/punt
--with-udev-rules-dir=$(get_udevdir)/rules.d
)
-
- xorg-2_pkg_setup
+ xorg-3_src_configure
}
src_install() {
- xorg-2_src_install
- rm -rf "${ED}"/punt
+ xorg-3_src_install
+ rm -r "${ED}"/punt || die
}
diff --git a/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-9999.ebuild b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-9999.ebuild
index 1a242a878474..6e59ab01e3c2 100644
--- a/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-9999.ebuild
+++ b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-9999.ebuild
@@ -1,30 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit udev xorg-2
+inherit udev xorg-3
DESCRIPTION="VMWare mouse input driver"
-IUSE=""
-KEYWORDS=""
RDEPEND=""
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
--with-hal-bin-dir=/punt
--with-hal-callouts-dir=/punt
--with-hal-fdi-dir=/punt
--with-udev-rules-dir=$(get_udevdir)/rules.d
)
-
- xorg-2_pkg_setup
+ xorg-3_src_configure
}
src_install() {
- xorg-2_src_install
- rm -rf "${ED}"/punt
+ xorg-3_src_install
+ rm -r "${ED}"/punt || die
}