summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-04-28 18:01:52 -0400
committerMike Pagano <mpagano@gentoo.org>2024-04-28 18:01:52 -0400
commitd5c8e2ddf25d79bc7ae4d401dbc5ad0327c40159 (patch)
tree5f15363deedeb47edf4d898fd566be790196a1bb
parentgames-kids/gmult: add 14.0 (diff)
downloadgentoo-d5c8e2ddf25d79bc7ae4d401dbc5ad0327c40159.tar.gz
gentoo-d5c8e2ddf25d79bc7ae4d401dbc5ad0327c40159.tar.bz2
gentoo-d5c8e2ddf25d79bc7ae4d401dbc5ad0327c40159.zip
sys-kernel/git-sources: add 6.9_rc6
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.9_rc6.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 6d1bb94b0408..f34c0cfd6a5f 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,2 +1,3 @@
DIST linux-6.8.tar.xz 142502100 BLAKE2B c6f17f816cea16e629f63e9379b98888713f57b2c5173306926471f139a9d612a0c74e119341f8075390e55e203d787d9edeb4ad5a064b18870f6f0f7ffaafb2 SHA512 5c4eb4aa1d3f7d1ea01c0f7ddeadacdece6e144fd4bdfc16b2b925d3e10dc04de3a6db69320b79a96c3560052616f001d2c09e7a1bb4f7b731e2380a7ecce068
DIST patch-6.9-rc5.patch 55017344 BLAKE2B ea645c33325c12c065cfe14998a64510526bf4691d5b13640a39e9f2039bd86e80197692e35d3f9c95483909166f4634cba90bf86c5ecf4da438ee278bba49b7 SHA512 7c93fde6455a9410abd4f6b00534876fb968f0f6f30c4eb26503e12dccf85b428dc7d1a23555549b3e385ebb59504b3f539b1070de9102a1ece51c1cd7cbc3da
+DIST patch-6.9-rc6.patch 55332584 BLAKE2B e4d4c1404b97304e7f1e2d50ad602c9c491ed9b12064f299ac5bfecf619f1407ff2814d9a119e48d2b2a4f1e2e19a95ec0233b2e16c29105443f83ca6cbbbfb9 SHA512 b05e3134daed7fecf6602273121b1b5b7d95152115e082494e63b66923e5e0b2c22fcaa821df0905d6ec1e298e52ebc2e5d35cad8312455dfd90abce4486ebc0
diff --git a/sys-kernel/git-sources/git-sources-6.9_rc6.ebuild b/sys-kernel/git-sources/git-sources-6.9_rc6.ebuild
new file mode 100644
index 000000000000..7068b44f8f6d
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.9_rc6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.8"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}