summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-26 09:14:10 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-26 10:07:12 +0200
commitd5e1ed6d991621d85f335d1286f72edcdcd0c78c (patch)
tree88a441720ff8fad1e6b41432e9e7041cf71ffd2b
parentdev-python/responses: Bump to 0.21.0 (diff)
downloadgentoo-d5e1ed6d991621d85f335d1286f72edcdcd0c78c.tar.gz
gentoo-d5e1ed6d991621d85f335d1286f72edcdcd0c78c.tar.bz2
gentoo-d5e1ed6d991621d85f335d1286f72edcdcd0c78c.zip
dev-python/pyenchant: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyenchant/pyenchant-3.2.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyenchant/pyenchant-3.2.2-r1.ebuild b/dev-python/pyenchant/pyenchant-3.2.2-r1.ebuild
new file mode 100644
index 000000000000..63112539edb8
--- /dev/null
+++ b/dev-python/pyenchant/pyenchant-3.2.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Enchant spellchecking system"
+HOMEPAGE="
+ https://github.com/pyenchant/pyenchant/
+ https://pypi.org/project/pyenchant/
+"
+SRC_URI="
+ https://github.com/pyenchant/pyenchant/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ app-text/enchant:*
+"
+BDEPEND="
+ test? (
+ app-dicts/myspell-en
+ )
+"
+
+distutils_enable_tests pytest