summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-04-25 17:47:08 +0500
committerViorel Munteanu <ceamac@gentoo.org>2024-04-29 11:46:46 +0300
commitd6c34a44245883bbfc1b451b6499c5380eb37b9b (patch)
treede6a8ba5e51851e409718ede7467cf03a5690455
parentwww-apps/hugo: add 0.125.4 (diff)
downloadgentoo-d6c34a44245883bbfc1b451b6499c5380eb37b9b.tar.gz
gentoo-d6c34a44245883bbfc1b451b6499c5380eb37b9b.tar.bz2
gentoo-d6c34a44245883bbfc1b451b6499c5380eb37b9b.zip
app-portage/gentle: add 1.0.0
Documentation bugs can be marked as resolved after v0.4.0 is dropped. Bug: https://bugs.gentoo.org/912768 Bug: https://bugs.gentoo.org/913548 Bug: https://bugs.gentoo.org/914436 Closes: https://bugs.gentoo.org/929351 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in> Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--app-portage/gentle/Manifest1
-rw-r--r--app-portage/gentle/gentle-1.0.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-portage/gentle/Manifest b/app-portage/gentle/Manifest
index 822c38d8bd8c..2a08ccea62ef 100644
--- a/app-portage/gentle/Manifest
+++ b/app-portage/gentle/Manifest
@@ -1,2 +1,3 @@
DIST gentle_mxml-0.3.1.tar.gz 141735 BLAKE2B 6720ff9af32d83beac66e5e8fc71cc33a7554edb000b835d4f770da199806ebfbc3bdd95954b738f21768da6b6f8315cb870e2185b8066d5f69cad85128f60ec SHA512 4722e37c635d7f1b492bf52f3f4003deda1ba65c79be56228009875241048d6976b38e836e62f6d90adb8ec1bc545ff903487759ad581ffc0bb2e371d25dd780
DIST gentle_mxml-0.4.0.tar.gz 329273 BLAKE2B baf6d954838d6cd2fc9548aaa33c85cb53307b325521a2fe300486a2cc08e833f835016ba632b484c1068c7deee3b2eeb17606f0180d248081304fa866b79461 SHA512 beac2c7bd3e4d80448fec5a633502e6cdc763145541b9205e3c354597b4e9c724f94cadb747b87df3c49669f5534cc9d123ded00b45b9cb783cd4e086a9b3ceb
+DIST gentle_mxml-1.0.0.tar.gz 356588 BLAKE2B bb5eddfd91876226cad27c6e2b06ac60926c7f1075c3c6838b2abf262b9a7ec7740083e8397a3980174d83d3c2b6fff67772adf2454fb11892a1624d27ebf533 SHA512 fdd9399545e6613b932de3bfc093815019941fcbba1535384a77431259320b478cd4a020ea3d657f1bf2a296a8f788fb9a08bc1c917b3c59e06d2a237f22a91a
diff --git a/app-portage/gentle/gentle-1.0.0.ebuild b/app-portage/gentle/gentle-1.0.0.ebuild
new file mode 100644
index 000000000000..1185c8483539
--- /dev/null
+++ b/app-portage/gentle/gentle-1.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=flit
+PYPI_PN="gentle-mxml"
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Gentoo Lazy Entry - a metadata.xml generator"
+HOMEPAGE="
+ https://gentle.sysrq.in
+ https://pypi.org/project/gentle-mxml/
+"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ sys-apps/portage[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-text/xmldiff[${PYTHON_USEDEP}]
+ dev-lang/perl
+ dev-lang/ruby:*
+ >=dev-python/build-1.2.0[${PYTHON_USEDEP}]
+ dev-python/pkginfo[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/insipid-sphinx-theme \
+ dev-python/sphinx-prompt
+
+python_test() {
+ epytest --with-perl --with-ruby
+}
+
+pkg_postinst() {
+ optfeature "python packaging support" dev-python/build
+ optfeature "PKG-INFO support" dev-python/pkginfo
+ optfeature "yaml support" dev-python/pyyaml
+ optfeature "rdf support" dev-python/rdflib
+}