summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokry <martin-kokos@users.noreply.github.com>2023-03-28 20:46:39 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-22 15:15:49 +0200
commitd706cc721af59b0fa114e953c42cdc7782dec1a8 (patch)
treeeab9f5dca00874b5b7cc0b709ed974bc97a048ae
parentdev-python/poetry-plugin-export: New package, v1.4.0 (diff)
downloadgentoo-d706cc721af59b0fa114e953c42cdc7782dec1a8.tar.gz
gentoo-d706cc721af59b0fa114e953c42cdc7782dec1a8.tar.bz2
gentoo-d706cc721af59b0fa114e953c42cdc7782dec1a8.zip
dev-python/poetry: New package, v1.5.1
Signed-off-by: Martin Mokry <martin-kokos@protonmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/poetry/Manifest1
-rw-r--r--dev-python/poetry/metadata.xml16
-rw-r--r--dev-python/poetry/poetry-1.5.1.ebuild92
3 files changed, 109 insertions, 0 deletions
diff --git a/dev-python/poetry/Manifest b/dev-python/poetry/Manifest
new file mode 100644
index 000000000000..7fe951512e55
--- /dev/null
+++ b/dev-python/poetry/Manifest
@@ -0,0 +1 @@
+DIST poetry-1.5.1.tar.gz 1469755 BLAKE2B ac60d6aabe69b1e46a6fbc188579034e716a470384571a611952489d175485cf997636c9206a53e29be073582e672f8010ab5f8f13b58a12dc644279753f903e SHA512 863bc4ea43b6fc5b340f50f007c76d2c253223d6bd55ea5c1ead4bc353c3d4cd85d51372a774276e14d9fca733fac9c2f582892fec950b74f25dc188dafa7a96
diff --git a/dev-python/poetry/metadata.xml b/dev-python/poetry/metadata.xml
new file mode 100644
index 000000000000..a87ee8e5007b
--- /dev/null
+++ b/dev-python/poetry/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>martin-kokos@protonmail.com</email>
+ <name>Martin Mokry</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">poetry</remote-id>
+ <remote-id type="github">python-poetry/poetry</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/poetry/poetry-1.5.1.ebuild b/dev-python/poetry/poetry-1.5.1.ebuild
new file mode 100644
index 000000000000..9fa3a6a19ab3
--- /dev/null
+++ b/dev-python/poetry/poetry-1.5.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A frontend for poetry - a python dependency management and packaging tool"
+HOMEPAGE="
+ https://python-poetry.org/
+ https://github.com/python-poetry/poetry
+ https://pypi.org/project/poetry/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/poetry-core-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/poetry-plugin-export-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/build-0.10.0[${PYTHON_USEDEP}]
+ >=dev-python/cleo-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/crashtest-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.21.2[${PYTHON_USEDEP}]
+ >=dev-python/installer-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.10.0[${PYTHON_USEDEP}]
+ >=dev-python/keyring-23.9.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
+ >=dev-python/pexpect-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.9.4[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/shellingham-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
+ >=dev-python/trove-classifiers-2022.5.19[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.22.0[${PYTHON_USEDEP}]
+ >=dev-python/cachecontrol-0.12.9[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ >=dev-python/deepdiff-6.3.1[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # Dependency on abandoned package cachy has been removed from poetry https://github.com/python-poetry/poetry/pull/5868
+ # and remains in tests only for time being, so we can skip them.
+ # removal of tests upstream https://github.com/python-poetry/poetry/pull/7437
+ sed -e "s/from cachy import CacheManager/from unittest import mock; CacheManager = mock.Mock # Gentoo ebuild patched/g" \
+ -i tests/console/commands/cache/conftest.py \
+ -i tests/utils/test_cache.py || die
+ sed -e 's:"cachy_file_cache", ::g' \
+ -i tests/utils/test_cache.py || die
+
+ distutils-r1_src_prepare
+}
+
+EPYTEST_DESELECT=(
+ # Dependency on abandoned package cachy has been removed from poetry https://github.com/python-poetry/poetry/pull/5868
+ # and remains in tests only for time being, so we can skip them.
+ # removal of tests upstream https://github.com/python-poetry/poetry/pull/7437
+ tests/console/commands/cache/test_clear.py::test_cache_clear_all
+ tests/console/commands/cache/test_clear.py::test_cache_clear_all_no
+ tests/console/commands/cache/test_clear.py::test_cache_clear_pkg
+ tests/console/commands/cache/test_clear.py::test_cache_clear_pkg_no
+ tests/utils/test_cache.py::test_cachy_compatibility
+
+ # Tests require network (they run `pip install ...`)
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_directories
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_git
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_git_with_subdirectories
+ tests/installation/test_pip_installer.py::test_uninstall_git_package_nspkg_pth_cleanup
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_non_wheel_files
+ tests/installation/test_installer.py::test_installer_with_pypi_repository
+
+ # Works with network, but otherwise: Backend 'poetry.core.masonry.api' is not available.
+ tests/installation/test_chef.py::test_prepare_sdist
+ tests/installation/test_chef.py::test_prepare_directory
+ tests/installation/test_chef.py::test_prepare_directory_with_extensions
+ tests/installation/test_chef.py::test_prepare_directory_editable
+)
+
+distutils_enable_tests pytest