summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-02-01 11:26:10 -0500
committerMatt Turner <mattst88@gentoo.org>2023-02-01 11:26:16 -0500
commitd776891bdc9f7ca08e19190e31db4eef9131e8aa (patch)
tree0fa9e1cab3b3f388b1f827a2d36bc3ebc2b9fe9b
parentsci-geosciences/gnome-maps: Version bump to 43.4 (diff)
downloadgentoo-d776891b.tar.gz
gentoo-d776891b.tar.bz2
gentoo-d776891b.zip
gui-libs/libhandy: Version bump to 1.8.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gui-libs/libhandy/Manifest1
-rw-r--r--gui-libs/libhandy/libhandy-1.8.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/gui-libs/libhandy/Manifest b/gui-libs/libhandy/Manifest
index 0ef0a30f7825..64424fe24ddf 100644
--- a/gui-libs/libhandy/Manifest
+++ b/gui-libs/libhandy/Manifest
@@ -1 +1,2 @@
DIST libhandy-1.8.0.tar.xz 1796032 BLAKE2B 15929cfde5e01b25e0ccc4dfa94bb0d12272b02a5c5196fcb3a85a898bf8384faa4101114e14f44d53f326fa5321254bba85e3c7f41e426ebd116e2d3dfd96ca SHA512 88f37d310ddc26a26612648d9f7beff6e77347a2cf59f682690dc838c3ec1bad9408ed39571c6cd779bea3d334a9c275ba3789d45c11c0a3e454617d41cc0035
+DIST libhandy-1.8.1.tar.xz 1801348 BLAKE2B 48d9f37f333bbebacd265a802c8fad6aa4c5a2c5ffaa879ee61fd02c92e10b9c60bd01f6bff0afe4573b6e8e3b16fc4633b25c98e5c7e0adb787161ee1aeee88 SHA512 ffcc8dfc0687e3410d1c1b10b56a974925688eee4a971baffc9adafc3585e5e3f4e91b04c6ab1aea99b1d582982a28bdc13c07cdf2af523e1af0d724229b4999
diff --git a/gui-libs/libhandy/libhandy-1.8.1.ebuild b/gui-libs/libhandy/libhandy-1.8.1.ebuild
new file mode 100644
index 000000000000..afdab98c45b1
--- /dev/null
+++ b/gui-libs/libhandy/libhandy-1.8.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson xdg vala virtualx
+
+DESCRIPTION="Building blocks for modern adaptive GNOME apps"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libhandy/"
+
+LICENSE="LGPL-2.1+"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="examples glade gtk-doc +introspection test +vala"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.24.1:3[introspection?]
+ glade? ( dev-util/glade:3.10= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1
+ app-text/docbook-xml-dtd:4.3 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofiling=false # -pg passing
+ $(meson_feature introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use test tests)
+ $(meson_use examples)
+ $(meson_feature glade glade_catalog)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}