summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-28 04:34:49 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-28 04:37:22 +0200
commitd9cb39bfa05f89568477130bd421b2fff8d821e9 (patch)
tree42fc6e93d70dde95ab6cdf4b8a5f841ec348cd4c
parentdev-python/cairocffi: Bump to 1.7.0 (diff)
downloadgentoo-d9cb39bfa05f89568477130bd421b2fff8d821e9.tar.gz
gentoo-d9cb39bfa05f89568477130bd421b2fff8d821e9.tar.bz2
gentoo-d9cb39bfa05f89568477130bd421b2fff8d821e9.zip
dev-python/paste: Bump to 3.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/paste/Manifest1
-rw-r--r--dev-python/paste/metadata.xml2
-rw-r--r--dev-python/paste/paste-3.10.0.ebuild40
3 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/paste/Manifest b/dev-python/paste/Manifest
index 0ee366881d32..c9dc5abd4300 100644
--- a/dev-python/paste/Manifest
+++ b/dev-python/paste/Manifest
@@ -1 +1,2 @@
+DIST Paste-3.10.0.tar.gz 651790 BLAKE2B a026f1121a0f6532a6afdd3cb87e0ae16437df0b69dccb900293ee7d1e35a56636bdd0fc379a340b63e400323ee9c728bca608a511d529e5457bba2c08e16deb SHA512 52a6b410564417659cb6f49d6e4b91268386f5e9a82be944b3128a11e37424766d42e9a9f082d682605258a96a57cde113f79c40e32fdaff023a04739c91325b
DIST Paste-3.9.0.tar.gz 637286 BLAKE2B 8bb21f2f6d46750dfff8d9e6377141ea1bcf12848e070138be76823d4dd2bd6be510e420f6568cdab631ab627d45ef93be9815141c6ce31544c4ed38487875e8 SHA512 a9099b89e17f597e853d82cc5d99aaf84fa71ee25e92a382a47a482982800a7e766d8389530ef2a7ad145771ebbabdb1ae5d8370d9cd30121b94e18bcaef3f81
diff --git a/dev-python/paste/metadata.xml b/dev-python/paste/metadata.xml
index e218c42fdc4b..a16d4c84e24a 100644
--- a/dev-python/paste/metadata.xml
+++ b/dev-python/paste/metadata.xml
@@ -11,7 +11,7 @@
those interfaces.</longdescription>
<stabilize-allarches/>
<upstream>
- <remote-id type="github">cdent/paste</remote-id>
+ <remote-id type="github">pasteorg/paste</remote-id>
<remote-id type="pypi">Paste</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/paste/paste-3.10.0.ebuild b/dev-python/paste/paste-3.10.0.ebuild
new file mode 100644
index 000000000000..21192970602d
--- /dev/null
+++ b/dev-python/paste/paste-3.10.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
+HOMEPAGE="
+ https://pythonpaste.readthedocs.io/en/latest/
+ https://github.com/pasteorg/paste/
+ https://pypi.org/project/Paste/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/test_proxy.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}