summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-05-03 13:47:36 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-03 13:48:43 +0300
commitdd38e7c04822e057068e3ec0c1f1104714f02709 (patch)
treec5092ce2c18bc999bd62673ad86754ef367cb912
parentapp-shells/bash-completion: add 2.13.0 (diff)
downloadgentoo-dd38e7c04822e057068e3ec0c1f1104714f02709.tar.gz
gentoo-dd38e7c04822e057068e3ec0c1f1104714f02709.tar.bz2
gentoo-dd38e7c04822e057068e3ec0c1f1104714f02709.zip
app-shells/bash-completion: sync live
Closes: https://bugs.gentoo.org/865511 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--app-shells/bash-completion/bash-completion-9999.ebuild25
1 files changed, 22 insertions, 3 deletions
diff --git a/app-shells/bash-completion/bash-completion-9999.ebuild b/app-shells/bash-completion/bash-completion-9999.ebuild
index d9a8954d6f32..452614926c31 100644
--- a/app-shells/bash-completion/bash-completion-9999.ebuild
+++ b/app-shells/bash-completion/bash-completion-9999.ebuild
@@ -13,7 +13,6 @@ EGIT_REPO_URI="https://github.com/scop/bash-completion"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS=""
IUSE="+eselect test"
RESTRICT="!test? ( test )"
@@ -29,6 +28,7 @@ BDEPEND="
$(python_gen_any_dep '
dev-python/pexpect[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
')
)
"
@@ -69,7 +69,8 @@ strip_completions() {
python_check_deps() {
python_has_version "dev-python/pexpect[${PYTHON_USEDEP}]" &&
- python_has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/pytest[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"
}
pkg_setup() {
@@ -102,7 +103,16 @@ src_test() {
test/t/test_if{down,up}.py
# not available for icedtea
test/t/test_javaws.py
+ # TODO
+ test/t/test_vi.py::TestVi::test_2
+ test/t/test_xmlwf.py::TestXmlwf::test_2 #bug 886159
+ test/t/test_xrandr.py::TestXrandr::test_output_filter
)
+ local EPYTEST_IGNORE=(
+ # stupid test that async tests work
+ test/fixtures/pytest/test_async.py
+ )
+ local EPYTEST_XDIST=1
# portage's HOME override breaks tests
local -x HOME=$(unset HOME; echo ~)
@@ -110,6 +120,7 @@ src_test() {
# used in pytest tests
local -x NETWORK=none
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked
emake -C completions check
epytest
}
@@ -122,7 +133,15 @@ src_install() {
strip_completions
- dodoc AUTHORS CHANGES CONTRIBUTING.md README.md
+ dodoc AUTHORS CHANGELOG.md CONTRIBUTING.md README.md
+
+ # install the python completions for all targets, bug #622892
+ local TARGET
+ for TARGET in "${PYTHON_COMPAT[@]}"; do
+ if [[ ! -e "${ED}"/usr/share/bash-completion/completions/${TARGET/_/.} ]]; then
+ dosym python "${ED}"/usr/share/bash-completion/completions/${TARGET/_/.}
+ fi
+ done
# install the eselect module
if use eselect; then