summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-02 10:11:56 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-02 10:26:54 +0100
commitddcbacd1cc534a140992e6ae98b47b8fa5607e6e (patch)
treea5837ee05d4da24fef970272a3fe130787f49cc9
parentdev-python/hyperframe: Switch to PEP 517 build (diff)
downloadgentoo-ddcbacd1.tar.gz
gentoo-ddcbacd1.tar.bz2
gentoo-ddcbacd1.zip
dev-python/hpack: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hpack/hpack-4.0.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/hpack/hpack-4.0.0-r1.ebuild b/dev-python/hpack/hpack-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..1a0ef6040ee2
--- /dev/null
+++ b/dev-python/hpack/hpack-4.0.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python HPACK header compression"
+HOMEPAGE="
+ https://python-hyper.org/projects/hpack/en/latest/
+ https://github.com/python-hyper/hpack/
+ https://pypi.org/project/hpack/"
+SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# dev-python/pytest-relaxed causes tests to fail
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ !!dev-python/pytest-relaxed[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest