summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-06 22:22:43 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-06 23:47:14 +0100
commitdf05214adf47e7b1184c735b70d3c5b4fea7e215 (patch)
tree77116384d6c93fe0af0a8ccafcd75ab655fae59f
parentapp-emacs/tempel: bump to 1.0 (diff)
downloadgentoo-df05214adf47e7b1184c735b70d3c5b4fea7e215.tar.gz
gentoo-df05214adf47e7b1184c735b70d3c5b4fea7e215.tar.bz2
gentoo-df05214adf47e7b1184c735b70d3c5b4fea7e215.zip
app-emacs/transient: bump to 0.5.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/transient/Manifest1
-rw-r--r--app-emacs/transient/transient-0.5.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/transient/Manifest b/app-emacs/transient/Manifest
index 2e5356e51f9e..a75d0ea00b8d 100644
--- a/app-emacs/transient/Manifest
+++ b/app-emacs/transient/Manifest
@@ -1,2 +1,3 @@
DIST transient-0.4.3.tar.gz 129365 BLAKE2B d07fb5cb6586950bd3561b2a7f77b6458db58531e7735d203dabbfd292facaf44af850de4f4824f6335f41afcf79d03c0291d31af31b84b4118ffb8cae996f2a SHA512 afa2f75a0d4d6d45af1e36f155371dad6a966073cbab9a3858eec020458530d21a34860b88ec4d1e1e93570675b9df6d5692ed8f8a1903478ee5085c9d2d039a
DIST transient-0.5.0.tar.gz 131312 BLAKE2B 4bf384c0a4f09863f541fb3d0e49542dae4c5da6a14ce7fd2f52af492809a7b0eab051134fdf3a06cefc1992746732a43b858349e63a0cdc271dcbf4b7352fe8 SHA512 3993dda7a39b3959d1eec91feb4e2bb345797d70d7c23bbd796f68309457090889b8d6c678cc2bb5872f76879a4d8a1cc5b14ac3d38abd9a57f2e06ad8d7001b
+DIST transient-0.5.2.tar.gz 133643 BLAKE2B 765d78c9c5bd756ff82a4857477350def4fc52a55e53f9f8b21e065a853d5ff4eacaa8507d30e4fb39ccb91a966cf71c06b5e5f3248768d1bc8476d67ef560c2 SHA512 d8cf45b302a960659ee6d306d71d32d4e8e614deca8033afe5e644f48f36fcb885e0cd9acf307b2e1ba2d3c99a32ca73cd7a0cd6ab78f8e3442fe4b01e3b04b8
diff --git a/app-emacs/transient/transient-0.5.2.ebuild b/app-emacs/transient/transient-0.5.2.ebuild
new file mode 100644
index 000000000000..ab8accfcb76d
--- /dev/null
+++ b/app-emacs/transient/transient-0.5.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Transient commands abstraction for GNU Emacs"
+HOMEPAGE="https://magit.vc/manual/transient/
+ https://github.com/magit/transient/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG README.org docs/${PN}.org )
+ELISP_TEXINFO="docs/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.1
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ default
+}