summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2024-03-10 22:49:15 +0100
committerSam James <sam@gentoo.org>2024-03-14 05:37:20 +0000
commite06d8192238f8e0c84bd891fbbfdc62efc52faed (patch)
tree6f488cd4cd9a63f28590f0f3fc296f25b99a1b32
parentdev-util/buildbot-www-react: add 3.11.1 (diff)
downloadgentoo-e06d8192238f8e0c84bd891fbbfdc62efc52faed.tar.gz
gentoo-e06d8192238f8e0c84bd891fbbfdc62efc52faed.tar.bz2
gentoo-e06d8192238f8e0c84bd891fbbfdc62efc52faed.zip
dev-util/buildbot-react-wsgi-dashboards: add 3.11.1
Signed-off-by: Magnus Granberg <zorry@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/buildbot-react-wsgi-dashboards/Manifest1
-rw-r--r--dev-util/buildbot-react-wsgi-dashboards/buildbot-react-wsgi-dashboards-3.11.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/buildbot-react-wsgi-dashboards/Manifest b/dev-util/buildbot-react-wsgi-dashboards/Manifest
index fc941a83677d..a46904e10adb 100644
--- a/dev-util/buildbot-react-wsgi-dashboards/Manifest
+++ b/dev-util/buildbot-react-wsgi-dashboards/Manifest
@@ -1 +1,2 @@
DIST buildbot-react-wsgi-dashboards-3.11.0.tar.gz 433325 BLAKE2B 636e8dcc101609243658ec6ebf1dcd6b62884b881b1296cf61fe877a7bb12d804222f55bb3e4f87d263823ebcc6d3fd28c8145c5167f3219baee7659345f0ad6 SHA512 3443ebf79e2d0a1913f8160ffad398f36304596e65c9691b728ee3e87b2b2878083623b8e3300c860a09f9a8e76de64b5be30191dc5e4e1a07ae457484ab98cf
+DIST buildbot-react-wsgi-dashboards-3.11.1.tar.gz 433325 BLAKE2B 0797efcbd30510315d2cc92a4390565fcb2feadd85ebcd33df1e1186769f4f0aaed9f2c69e4a59cd71aca2e79b3f43cdf8b82963124f1a611c8e33e9b4fbc54e SHA512 d7f52504bff8fe3394de0b4495aa184cb063f14a11885706482d0f8f1a8dfc56baeb550a2d404e3d4b4a98b3aada3063fc68549bd0e7227722fccb7fbe1b1505
diff --git a/dev-util/buildbot-react-wsgi-dashboards/buildbot-react-wsgi-dashboards-3.11.1.ebuild b/dev-util/buildbot-react-wsgi-dashboards/buildbot-react-wsgi-dashboards-3.11.1.ebuild
new file mode 100644
index 000000000000..a3fb0a32bd39
--- /dev/null
+++ b/dev-util/buildbot-react-wsgi-dashboards/buildbot-react-wsgi-dashboards-3.11.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Buildbot plugin to integrate flask or bottle dashboards to buildbot UI"
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-react-wsgi-dashboards/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-react-${PV}[${PYTHON_USEDEP}]
+"