summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWim Muskee <wimmuskee@gmail.com>2019-10-26 09:13:28 +0200
committerMatt Turner <mattst88@gentoo.org>2019-11-22 16:27:56 -0500
commite4f2acc7b9acd7b0264def7ab2bdc5c59708b4a4 (patch)
treeace2105291c43c7aa09636f21b871e07ddb930fd
parentdev-python/twine: Version bump to 1.15.0 (diff)
downloadgentoo-e4f2acc7.tar.gz
gentoo-e4f2acc7.tar.bz2
gentoo-e4f2acc7.zip
app-text/iso-codes: bump to 4.4
Closes: https://bugs.gentoo.org/699920 Signed-off-by: Wim Muskee <wimmuskee@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/13444 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-text/iso-codes/Manifest1
-rw-r--r--app-text/iso-codes/iso-codes-4.4.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/app-text/iso-codes/Manifest b/app-text/iso-codes/Manifest
index 176e81708d69..2688b2e11990 100644
--- a/app-text/iso-codes/Manifest
+++ b/app-text/iso-codes/Manifest
@@ -1 +1,2 @@
DIST iso-codes-3.76.tar.xz 3474728 BLAKE2B b418b7b80d1926e765b65aad4edbd74ad8d37251fda14e3ab0e222095762d54e358de6f8d4a08fde8ae14460fd975a2a541ca6a5a4cf8ef1d777719462b0f991 SHA512 a0f6714a79a52b5dab82a268e85cb2d019ff5255744b88d088dcd7d5a15eb9710876a338a0a5d0f5659b4146bc6cc53d6d3474d621b3dcca7c47afabfc7e0dfa
+DIST iso-codes-4.4.tar.gz 13299605 BLAKE2B 485f3b0240f1892fb96f2b5c391b3f0adc593fac97d53748aa104208936d1bf81de1d40e742ab48e3663cea0ce5b28a20782df2f4eed251bab5b8a7055745d0e SHA512 d22ecdef75cd07b59ea0dbc87d25eb254676ab83297c1a43dbad9d3471ba355630f5588b4590972526f9e885b2e1ec307303ac0bb94b2dd5c707377c1cfa64d8
diff --git a/app-text/iso-codes/iso-codes-4.4.ebuild b/app-text/iso-codes/iso-codes-4.4.ebuild
new file mode 100644
index 000000000000..5494c38bf591
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-4.4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+PLOCALES="ab ace ach af ak am an ar as ast ay az ba bar be bg bi bn bn_IN br bs byn ca ce ch chr ckb crh cs csb cv cy da de dv dz ee el en eo es et eu fa ff fi fo fr frp fur fy ga gez gl gn gu gv ha haw he hi hr ht hu hy ia id io is it iu ja jam ka kab ki kk kl km kn ko kok ku kv kw ky lo lt lv mai mhr mi mk ml mn mo mr ms mt my na nah nb nb_NO ne nl nn nso nv oc or pa pap pi pl ps pt pt_BR ro ru rw sc sd si sk sl so son sq sr sr@latin sv sw ta te tg th ti tig tk tl tr tt tt@iqtelif ug uk ur uz ve vi wa wal wo xh yo zh_CN zh_HK zh_Hant zh_TW zu"
+
+inherit python-any-r1
+
+DESCRIPTION="ISO language, territory, currency, script codes and their translations"
+HOMEPAGE="https://salsa.debian.org/iso-codes-team/iso-codes"
+SRC_URI="https://salsa.debian.org/${PN}-team/${PN}/-/archive/${P}/${PN}-${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext
+"
+S="${WORKDIR}/${PN}-${P}"
+
+# This ebuild does not install any binaries.
+RESTRICT="binchecks strip"
+
+# l10n_find_plocales_changes doesn't support multiple directories,
+# so need to do the update scan ourselves.
+check_existing_locales() {
+ local std loc all_locales=()
+
+ ebegin "Looking for new locales"
+ for std in "${all_stds[@]}"; do
+ pushd "${std}" >/dev/null || die
+ for loc in *.po; do
+ all_locales+=( "${loc%.po}" )
+ done
+ popd >/dev/null
+ done
+
+ all_locales=$(echo $(printf '%s\n' "${all_locales[@]}" | LC_COLLATE=C sort -u))
+ if [[ ${PLOCALES} != "${all_locales}" ]]; then
+ eend 1
+ eerror "There are changes in locales! This ebuild should be updated to:"
+ eerror "PLOCALES=\"${all_locales}\""
+ die "Update PLOCALES in the ebuild"
+ else
+ eend 0
+ fi
+}
+
+src_prepare() {
+ default
+
+ local std loc mylinguas
+ local all_stds=( iso_15924 iso_3166-{1,2,3} iso_4217 iso_639-{2,3,5} )
+
+ check_existing_locales
+
+ # Modify the Makefiles so they only install requested locales.
+ for std in "${all_stds[@]}"; do
+ einfo "Preparing ${std} ..."
+ pushd "${std}" >/dev/null || die
+ mylinguas=()
+ for loc in *.po; do
+ if has ${loc%.po} ${LINGUAS-${loc%.po}}; then
+ mylinguas+=( "${loc}" )
+ fi
+ done
+
+ sed \
+ -e "/^pofiles =/s:=.*:= ${mylinguas[*]}:" \
+ -e "/^mofiles =/s:=.*:= ${mylinguas[*]/%.po/.mo}:" \
+ -i Makefile.am Makefile.in || die "sed in ${std} folder failed"
+ popd >/dev/null
+ done
+}