summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2016-01-19 10:31:39 +0000
committerTony Vroon <chainsaw@gentoo.org>2016-01-19 10:31:59 +0000
commite7d29f9c85b47fea5a96bdefc09e359ec1212209 (patch)
treebf4b28f55a51b0eab0449a5f3730843fd45d5712
parentdev-lang/go-bootstrap: marked ~x64-solaris (diff)
downloadgentoo-e7d29f9c.tar.gz
gentoo-e7d29f9c.tar.bz2
gentoo-e7d29f9c.zip
net-misc/sipsak: GCC 5 compatibility patch by Thomas "whissi" D. in bug #568588.
Package-Manager: portage-2.2.26
-rw-r--r--net-misc/sipsak/sipsak-0.9.6_p1-r2.ebuild (renamed from net-misc/sipsak/sipsak-0.9.6_p1.ebuild)20
1 files changed, 13 insertions, 7 deletions
diff --git a/net-misc/sipsak/sipsak-0.9.6_p1.ebuild b/net-misc/sipsak/sipsak-0.9.6_p1-r2.ebuild
index 65671264e054..9810ba98e8e9 100644
--- a/net-misc/sipsak/sipsak-0.9.6_p1.ebuild
+++ b/net-misc/sipsak/sipsak-0.9.6_p1-r2.ebuild
@@ -1,27 +1,33 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=2
+EAPI=5
+
+inherit eutils flag-o-matic
DESCRIPTION="small command line tool for testing SIP applications and devices"
-HOMEPAGE="http://sipsak.org/"
-#SRC_URI="mirror://berlios/sipsak/${P/_p/-}.tar.gz"
-SRC_URI="mirror://gentoo/${P/_p/-}.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/sipsak.berlios/"
+SRC_URI="mirror://sourceforge/sipsak.berlios/${P/_p/-}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc x86 ~x86-fbsd"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
IUSE="gnutls"
RDEPEND="gnutls? ( net-libs/gnutls )
net-dns/c-ares"
-# ares? ( net-dns/c-ares )"
DEPEND="${RDEPEND}"
S=${WORKDIR}/${P/_p1}
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-callback.patch"
+}
+
src_configure() {
+ append-cflags -std=gnu89
+
econf \
$(use_enable gnutls)
}