summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2022-09-14 23:15:31 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2022-09-14 23:20:46 +0300
commitecc2b632d84cca11c5b408adbb0f2a248af79dd6 (patch)
treec6010db46bd25f4974442bc93f03edf539f8e842
parentdev-embedded/platformio: Add udev_reload (diff)
downloadgentoo-ecc2b632d84cca11c5b408adbb0f2a248af79dd6.tar.gz
gentoo-ecc2b632d84cca11c5b408adbb0f2a248af79dd6.tar.bz2
gentoo-ecc2b632d84cca11c5b408adbb0f2a248af79dd6.zip
dev-embedded/platformio: add 6.1.4
Closes: https://bugs.gentoo.org/862085 Signed-off-by: Alexey Shvetsov (Alexey Shvetsov) <alexxy@gentoo.org>
-rw-r--r--dev-embedded/platformio/Manifest1
-rw-r--r--dev-embedded/platformio/platformio-6.1.4.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/dev-embedded/platformio/Manifest b/dev-embedded/platformio/Manifest
index 9756ab40a050..c0feb85128e1 100644
--- a/dev-embedded/platformio/Manifest
+++ b/dev-embedded/platformio/Manifest
@@ -1 +1,2 @@
DIST platformio-6.0.2.tar.gz 285452 BLAKE2B c70523837b5118fcc1209a36a425fb6ab0aac73e56732916ff3d39fe87d50a47bf7d31d77324f491093ed366b1b3e4f88274e973bc896b164f5a07687a53bd12 SHA512 a2e48ad9ca22024a06509a9e36e5a7586088d0e8abd67d309d1988a8a112a41e301f077f1b466b5db390dc4048add570acd5bb762bbf22db69715dead0d8fc89
+DIST platformio-6.1.4.tar.gz 290408 BLAKE2B 41a977d9b5e51a1e65ef61973301ab6e7e9ad0adbe6d4df2640b13f46623055df8303435a664acdd267ad8811229687b6abb088d5b331c33fb46bbe33ab188b1 SHA512 8c46b21212de2fb7579540c51b17061666b8abe4706800fe30fea053cb4233c17a03c2388295f9fb3a21602126f0c2c13f1dd80db962ef1b3d5c31c9a30791c7
diff --git a/dev-embedded/platformio/platformio-6.1.4.ebuild b/dev-embedded/platformio/platformio-6.1.4.ebuild
new file mode 100644
index 000000000000..827140a1feaa
--- /dev/null
+++ b/dev-embedded/platformio/platformio-6.1.4.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 udev
+
+DESCRIPTION="An open source ecosystem for IoT development"
+HOMEPAGE="https://platformio.org/"
+SRC_URI="https://github.com/platformio/platformio-core/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-core-${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ <dev-python/aiofiles-0.9[${PYTHON_USEDEP}]
+ dev-python/ajsonrpc[${PYTHON_USEDEP}]
+ <dev-python/bottle-0.13[${PYTHON_USEDEP}]
+ >=dev-python/click-8[${PYTHON_USEDEP}]
+ <dev-python/click-9[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/pyserial-3[${PYTHON_USEDEP}]
+ <dev-python/pyserial-4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ >=dev-python/semantic_version-2.9[${PYTHON_USEDEP}]
+ <dev-python/semantic_version-3[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.3[${PYTHON_USEDEP}]
+ <dev-python/tabulate-1[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ >=dev-python/pyelftools-0.25[${PYTHON_USEDEP}]
+ <dev-python/pyelftools-1[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-2.20.5[${PYTHON_USEDEP}]
+ =dev-python/starlette-0.18*[${PYTHON_USEDEP}]
+ =dev-python/uvicorn-0.17*[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ >=dev-python/zeroconf-0.37[${PYTHON_USEDEP}]
+ ')
+ virtual/udev"
+DEPEND="virtual/udev"
+BDEPEND="test? ( $(python_gen_cond_dep 'dev-python/jsondiff[${PYTHON_USEDEP}]') )"
+
+# This list could be refined a bit to have individual tests which need network
+# (within EPYTEST_DESELECT) but so many need it that it doesn't seem worth it right now.
+EPYTEST_IGNORE=(
+ # Requires network access
+ tests/test_builder.py
+ tests/package/test_manager.py
+ tests/package/test_manifest.py
+ tests/commands/test_platform.py
+ tests/commands/test_test.py
+ tests/commands/test_ci.py
+ tests/commands/test_init.py
+ tests/commands/test_lib.py
+ tests/commands/test_lib_complex.py
+ tests/commands/test_boards.py
+ tests/commands/test_check.py
+ tests/commands/test_run.py
+ tests/commands/pkg/test_exec.py
+ tests/commands/pkg/test_list.py
+ tests/commands/pkg/test_outdated.py
+ tests/commands/pkg/test_search.py
+ tests/commands/pkg/test_show.py
+ tests/commands/pkg/test_install.py
+ tests/commands/pkg/test_uninstall.py
+ tests/commands/pkg/test_update.py
+ tests/misc/ino2cpp/test_ino2cpp.py
+ tests/test_maintenance.py
+ tests/test_misc.py
+)
+
+EPYTEST_DESELECT=(
+ # Requires network access
+ tests/misc/test_maintenance.py::test_check_pio_upgrade
+ tests/misc/test_misc.py::test_ping_internet_ips
+ tests/misc/test_misc.py::test_api_cache
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Allow newer versions of zeroconf, Bug #831181.
+ # Also wsproto.
+ # ... and semantic_version, bug #853247.
+ sed \
+ -e '/zeroconf/s/<[0-9.*]*//' \
+ -e '/wsproto/s/==.*/"/' \
+ -e '/semantic_version/s/==[0-9.*]*//' \
+ -i setup.py || die
+
+ default
+}
+
+python_test() {
+ epytest -k "not skip_ci"
+}
+
+src_install() {
+ distutils-r1_src_install
+ udev_dorules scripts/99-platformio-udev.rules
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}