summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-30 17:33:32 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-30 17:35:58 +0100
commited03aa5877874406454c8ca58aec6489302cce19 (patch)
tree4a06d4d0aa9b281b90b197835ac076d3e222d1ac
parentdev-python/furo: Unpack when PKGBUMPING, to make diffing possible (diff)
downloadgentoo-ed03aa5877874406454c8ca58aec6489302cce19.tar.gz
gentoo-ed03aa5877874406454c8ca58aec6489302cce19.tar.bz2
gentoo-ed03aa5877874406454c8ca58aec6489302cce19.zip
dev-python/jupyterlab-pygments: Unpack when PKGBUMPING
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyterlab-pygments/jupyterlab-pygments-0.3.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/jupyterlab-pygments/jupyterlab-pygments-0.3.0.ebuild b/dev-python/jupyterlab-pygments/jupyterlab-pygments-0.3.0.ebuild
index c65f97d65077..f29e5a551aaa 100644
--- a/dev-python/jupyterlab-pygments/jupyterlab-pygments-0.3.0.ebuild
+++ b/dev-python/jupyterlab-pygments/jupyterlab-pygments-0.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -24,6 +24,12 @@ RDEPEND="
dev-python/pygments[${PYTHON_USEDEP}]
"
+src_unpack() {
+ if [[ ${PKGBUMPING} == ${PVR} ]]; then
+ unzip "${DISTDIR}/${A}" || die
+ fi
+}
+
python_compile() {
distutils_wheel_install "${BUILD_DIR}/install" \
"${DISTDIR}/$(pypi_wheel_name)"