summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2020-11-29 22:23:23 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2020-11-29 22:23:23 -0500
commitef5d69fa03126598af4ee4b1949fb7d9d4bb075f (patch)
tree32270761ccc7a9153e5288eabed71f3be086ff3b
parentprofiles/prefix/darwin/macos/package.mask: unmask =sys-devel/gettext-0.21 (diff)
downloadgentoo-ef5d69fa.tar.gz
gentoo-ef5d69fa.tar.bz2
gentoo-ef5d69fa.zip
dev-db/pg_top: Don't ignore CFLAGS
Bug: https://bugs.gentoo.org/756049 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
-rw-r--r--dev-db/pg_top/pg_top-4.0.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-db/pg_top/pg_top-4.0.0-r1.ebuild b/dev-db/pg_top/pg_top-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..bb38e3056d70
--- /dev/null
+++ b/dev-db/pg_top/pg_top-4.0.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="'top' for PostgreSQL"
+HOMEPAGE="https://pg_top.gitlab.io/"
+SRC_URI="https://pg_top.gitlab.io/source/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-db/postgresql:="
+DEPEND="${RDEPEND}"
+
+DOCS=( HISTORY.rst README.rst TODO Y2K )
+
+src_prepare() {
+ sed 's/set(CMAKE_C_FLAGS "-Wall")//' -i CMakeLists.txt || die
+ cmake_src_prepare
+}