summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-05 16:26:28 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-05 16:26:33 +0200
commitef7a884b7d69b42c30a59c68bcd97f3e9d1fa7a4 (patch)
tree768e0d9d25b57cfc2549a2814e563d694f83cdb4
parentsci-chemistry/nmrglue: add 0.9 (diff)
downloadgentoo-ef7a884b7d69b42c30a59c68bcd97f3e9d1fa7a4.tar.gz
gentoo-ef7a884b7d69b42c30a59c68bcd97f3e9d1fa7a4.tar.bz2
gentoo-ef7a884b7d69b42c30a59c68bcd97f3e9d1fa7a4.zip
sci-misc/vitables: update EAPI 7 -> 8, PEP517, enable py3_10
Closes: https://bugs.gentoo.org/846284 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-misc/vitables/vitables-3.0.2-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-misc/vitables/vitables-3.0.2-r1.ebuild b/sci-misc/vitables/vitables-3.0.2-r1.ebuild
new file mode 100644
index 000000000000..3b9e8f66f750
--- /dev/null
+++ b/sci-misc/vitables/vitables-3.0.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN="ViTables"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A graphical tool for browsing / editing files in both PyTables and HDF5 formats"
+HOMEPAGE="https://vitables.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/QtPy[gui,${PYTHON_USEDEP}]
+ ')"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ <dev-python/sip-5[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+distutils_enable_tests pytest