summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-30 13:24:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-30 14:03:50 +0200
commitef8cbd7d4e99b18da4956dec6dabdb173c2bcca5 (patch)
treec3ed0222211ac706d01380e44ef9015e982e9ecb
parentdev-ros/navfn: Initial import. Ebuild by me. (diff)
downloadgentoo-ef8cbd7d.tar.gz
gentoo-ef8cbd7d.tar.bz2
gentoo-ef8cbd7d.zip
dev-ros/base_local_planner: Initial import. Ebuild by me.
Package-Manager: portage-2.2.22
-rw-r--r--dev-ros/base_local_planner/Manifest1
-rw-r--r--dev-ros/base_local_planner/base_local_planner-1.13.0.ebuild37
-rw-r--r--dev-ros/base_local_planner/base_local_planner-9999.ebuild37
-rw-r--r--dev-ros/base_local_planner/metadata.xml5
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-ros/base_local_planner/Manifest b/dev-ros/base_local_planner/Manifest
new file mode 100644
index 000000000000..2ab0c74f2366
--- /dev/null
+++ b/dev-ros/base_local_planner/Manifest
@@ -0,0 +1 @@
+DIST navigation-1.13.0.tar.gz 336419 SHA256 5ef288325a0de4accfb4ef0cc37d9e9c4106a05d98b0ae5757f6c4823abada97 SHA512 1b686d4d1e930901dcf899fb73c8609855c3bb6d797322f6f3b9ea7ccb349f98802870b44e0fcbee4e68abebeecbaff57d453dc790fbc908cd23b8afda22e1af WHIRLPOOL 096103d8b774205995a12d294c820187fb89302285b363f6e6b9a4bb1e30a2edf9b33a451effc00b8aeec4d8f40664f61266314d389b9c668c0d7cf2152f70dd
diff --git a/dev-ros/base_local_planner/base_local_planner-1.13.0.ebuild b/dev-ros/base_local_planner/base_local_planner-1.13.0.ebuild
new file mode 100644
index 000000000000..a6369ac09c2f
--- /dev/null
+++ b/dev-ros/base_local_planner/base_local_planner-1.13.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Trajectory Rollout and Dynamic Window approaches to local robot navigation on a plane"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/pcl_conversions
+ dev-ros/rostest
+ dev-ros/costmap_2d
+ dev-ros/pluginlib
+ dev-ros/angles
+ dev-libs/boost:=[threads]
+ dev-cpp/eigen:3
+ sci-libs/pcl
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? ( dev-cpp/gtest )
+"
diff --git a/dev-ros/base_local_planner/base_local_planner-9999.ebuild b/dev-ros/base_local_planner/base_local_planner-9999.ebuild
new file mode 100644
index 000000000000..a6369ac09c2f
--- /dev/null
+++ b/dev-ros/base_local_planner/base_local_planner-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Trajectory Rollout and Dynamic Window approaches to local robot navigation on a plane"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/pcl_conversions
+ dev-ros/rostest
+ dev-ros/costmap_2d
+ dev-ros/pluginlib
+ dev-ros/angles
+ dev-libs/boost:=[threads]
+ dev-cpp/eigen:3
+ sci-libs/pcl
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? ( dev-cpp/gtest )
+"
diff --git a/dev-ros/base_local_planner/metadata.xml b/dev-ros/base_local_planner/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/base_local_planner/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>