summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-08-15 07:42:19 +0200
committerMichał Górny <mgorny@gentoo.org>2015-08-15 07:44:57 +0200
commitf1a1ce103ab659640dd4a20901f2d2e7a72b6336 (patch)
treef187e8fd61cf2718beb557628e57cd85be12a614
parentdev-ruby/rails-dom-testing: version bump (diff)
downloadgentoo-f1a1ce103ab659640dd4a20901f2d2e7a72b6336.tar.gz
gentoo-f1a1ce103ab659640dd4a20901f2d2e7a72b6336.tar.bz2
gentoo-f1a1ce103ab659640dd4a20901f2d2e7a72b6336.zip
dev-python/pypy*: Fix USE=-ncurses and USE=-gdbm
Fix USE=-ncurses (and USE=-gdbm in pypy-2.6.0) not to try to regenerate cffi modules for the two. Bug: https://bugs.gentoo.org/show_bug.cgi?id=557540#c3 Package-Manager: portage-2.2.20
-rw-r--r--dev-python/pypy/pypy-2.4.0.ebuild4
-rw-r--r--dev-python/pypy/pypy-2.5.1.ebuild4
-rw-r--r--dev-python/pypy/pypy-2.6.0.ebuild3
-rw-r--r--dev-python/pypy3/pypy3-2.4.0.ebuild4
4 files changed, 11 insertions, 4 deletions
diff --git a/dev-python/pypy/pypy-2.4.0.ebuild b/dev-python/pypy/pypy-2.4.0.ebuild
index 15faabb3d294..352913b2c2aa 100644
--- a/dev-python/pypy/pypy-2.4.0.ebuild
+++ b/dev-python/pypy/pypy-2.4.0.ebuild
@@ -203,11 +203,13 @@ src_install() {
# Generate cffi cache
# Please keep in sync with pypy/tool/release/package.py!
- "${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
"${PYTHON}" -c "import syslog" || die "Failed to import syslog (cffi)"
if use gdbm; then
"${PYTHON}" -c "import gdbm" || die "Failed to import gdbm (cffi)"
fi
+ if use ncurses; then
+ "${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
+ fi
if use sqlite; then
"${PYTHON}" -c "import _sqlite3" || die "Failed to import _sqlite3 (cffi)"
fi
diff --git a/dev-python/pypy/pypy-2.5.1.ebuild b/dev-python/pypy/pypy-2.5.1.ebuild
index c07de498ec7d..109ebeb41543 100644
--- a/dev-python/pypy/pypy-2.5.1.ebuild
+++ b/dev-python/pypy/pypy-2.5.1.ebuild
@@ -203,11 +203,13 @@ src_install() {
# Generate cffi cache
# Please keep in sync with pypy/tool/release/package.py!
- "${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
"${PYTHON}" -c "import syslog" || die "Failed to import syslog (cffi)"
if use gdbm; then
"${PYTHON}" -c "import gdbm" || die "Failed to import gdbm (cffi)"
fi
+ if use ncurses; then
+ "${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
+ fi
if use sqlite; then
"${PYTHON}" -c "import _sqlite3" || die "Failed to import _sqlite3 (cffi)"
fi
diff --git a/dev-python/pypy/pypy-2.6.0.ebuild b/dev-python/pypy/pypy-2.6.0.ebuild
index d73cb5e5c1c0..18a8810327d8 100644
--- a/dev-python/pypy/pypy-2.6.0.ebuild
+++ b/dev-python/pypy/pypy-2.6.0.ebuild
@@ -217,8 +217,9 @@ src_install() {
# "syslog": "_syslog_build.py" if sys.platform != "win32" else None,
# "gdbm": "_gdbm_build.py" if sys.platform != "win32" else None,
# "pwdgrp": "_pwdgrp_build.py" if sys.platform != "win32" else None,
- cffi_targets=( audioop curses syslog gdbm pwdgrp )
+ cffi_targets=( audioop syslog pwdgrp )
use gdbm && cffi_targets+=( gdbm )
+ use ncurses && cffi_targets+=( curses )
use sqlite && cffi_targets+=( sqlite3 )
use tk && cffi_targets+=( tkinter/tklib )
diff --git a/dev-python/pypy3/pypy3-2.4.0.ebuild b/dev-python/pypy3/pypy3-2.4.0.ebuild
index 20b01f34f5f5..0c369adb0be0 100644
--- a/dev-python/pypy3/pypy3-2.4.0.ebuild
+++ b/dev-python/pypy3/pypy3-2.4.0.ebuild
@@ -197,11 +197,13 @@ src_install() {
# Generate cffi cache
# Please keep in sync with pypy/tool/release/package.py!
- "${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
"${PYTHON}" -c "import syslog" || die "Failed to import syslog (cffi)"
if use gdbm; then
"${PYTHON}" -c "import _gdbm" || die "Failed to import gdbm (cffi)"
fi
+ if use ncurses; then
+ "${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
+ fi
if use sqlite; then
"${PYTHON}" -c "import _sqlite3" || die "Failed to import _sqlite3 (cffi)"
fi