summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-02-20 21:51:54 +0100
committerDavid Seifert <soap@gentoo.org>2023-02-20 21:51:54 +0100
commitf3b128939f93ca09861c6e99171e6d0481895847 (patch)
tree808b7939fb108795a0f06d1e6329d27b80429ea8
parentx11-themes/zukitwo: treeclean (diff)
downloadgentoo-f3b128939f93ca09861c6e99171e6d0481895847.tar.gz
gentoo-f3b128939f93ca09861c6e99171e6d0481895847.tar.bz2
gentoo-f3b128939f93ca09861c6e99171e6d0481895847.zip
x11-wm/aewm++: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--x11-wm/aewm++/aewm++-1.1.5-r3.ebuild (renamed from x11-wm/aewm++/aewm++-1.1.5-r2.ebuild)13
-rw-r--r--x11-wm/aewm++/files/aewm++-1.1.5-gcc43.patch53
-rw-r--r--x11-wm/aewm++/files/aewm++-1.1.5-makefile.patch34
3 files changed, 69 insertions, 31 deletions
diff --git a/x11-wm/aewm++/aewm++-1.1.5-r2.ebuild b/x11-wm/aewm++/aewm++-1.1.5-r3.ebuild
index 47ceef425b86..1afc79dbe2dc 100644
--- a/x11-wm/aewm++/aewm++-1.1.5-r2.ebuild
+++ b/x11-wm/aewm++/aewm++-1.1.5-r3.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit toolchain-funcs
DESCRIPTION="A window manager with more modern features than aewm"
@@ -11,9 +12,9 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXext"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
@@ -23,6 +24,6 @@ PATCHES=(
"${FILESDIR}"/${P}-makefile.patch
)
-src_compile() {
- emake CXX="$(tc-getCXX)"
+src_configure() {
+ tc-export CXX
}
diff --git a/x11-wm/aewm++/files/aewm++-1.1.5-gcc43.patch b/x11-wm/aewm++/files/aewm++-1.1.5-gcc43.patch
index 23cacdc43a2b..1fab782112d2 100644
--- a/x11-wm/aewm++/files/aewm++-1.1.5-gcc43.patch
+++ b/x11-wm/aewm++/files/aewm++-1.1.5-gcc43.patch
@@ -1,6 +1,16 @@
-diff -ur aewm++-1.1.5.orig/client.cc aewm++-1.1.5/client.cc
---- aewm++-1.1.5.orig/client.cc 2005-05-23 06:06:01.000000000 +0300
-+++ aewm++-1.1.5/client.cc 2008-05-03 23:50:02.000000000 +0300
+--- a/aewm.hh
++++ b/aewm.hh
+@@ -87,7 +87,7 @@
+ #define BW (has_border ? wm->getOptBW() : 0)
+
+ // defined in main.cc
+-void forkExec(char *);
++void forkExec(const char *);
+ int handleXError(Display *, XErrorEvent *);
+
+ class Client;
+--- a/client.cc
++++ b/client.cc
@@ -6,6 +6,8 @@
*/
#include "aewm.hh"
@@ -10,21 +20,22 @@ diff -ur aewm++-1.1.5.orig/client.cc aewm++-1.1.5/client.cc
Client::Client(Display *d, Window new_client)
{
initialize(d);
-diff -ur aewm++-1.1.5.orig/main.cc aewm++-1.1.5/main.cc
---- aewm++-1.1.5.orig/main.cc 2005-02-12 05:38:32.000000000 +0200
-+++ aewm++-1.1.5/main.cc 2008-05-03 23:50:02.000000000 +0300
-@@ -6,6 +6,8 @@
+--- a/main.cc
++++ b/main.cc
+@@ -6,8 +6,10 @@
*/
#include "aewm.hh"
+#include <string.h>
+
// Dunno where I ripped this from. Kudos to the author whoever he is!
- void forkExec(char *cmd)
+-void forkExec(char *cmd)
++void forkExec(const char *cmd)
{
-diff -ur aewm++-1.1.5.orig/windowmanager.cc aewm++-1.1.5/windowmanager.cc
---- aewm++-1.1.5.orig/windowmanager.cc 2005-05-17 04:41:42.000000000 +0300
-+++ aewm++-1.1.5/windowmanager.cc 2008-05-03 23:50:02.000000000 +0300
+ if(! (strlen(cmd)>0)) return;
+
+--- a/windowmanager.cc
++++ b/windowmanager.cc
@@ -6,6 +6,8 @@
*/
#include "aewm.hh"
@@ -34,3 +45,23 @@ diff -ur aewm++-1.1.5.orig/windowmanager.cc aewm++-1.1.5/windowmanager.cc
WindowManager* wm;
#define AEWM_KEY_ALT_COUNT 4
+@@ -1020,7 +1022,7 @@
+ {
+ cleanup();
+
+- execl("/bin/sh", "sh", "-c", command_line.c_str(), 0);
++ execl("/bin/sh", "sh", "-c", command_line.c_str(), (const char*)NULL);
+ }
+
+ void WindowManager::quitNicely()
+--- a/windowmanager.hh
++++ b/windowmanager.hh
+@@ -46,7 +46,7 @@
+ string command_line;
+ int max_desktops;
+ int focus_model;
+- char *opt_display,
++ const char *opt_display,
+ *opt_fc,
+ *opt_fg,
+ *opt_fm,
diff --git a/x11-wm/aewm++/files/aewm++-1.1.5-makefile.patch b/x11-wm/aewm++/files/aewm++-1.1.5-makefile.patch
index 8b84a9963469..3066b0981a1f 100644
--- a/x11-wm/aewm++/files/aewm++-1.1.5-makefile.patch
+++ b/x11-wm/aewm++/files/aewm++-1.1.5-makefile.patch
@@ -1,29 +1,35 @@
-Respect CFLAGS, LDFLAGS, don't strip binaries
+* Respect CXX, CXXFLAGS, LDFLAGS, LIBS
+* Don't strip binaries
+https://bugs.gentoo.org/336099
-http://bugs.gentoo.org/show_bug.cgi?id=336099
-
---- aewm++-1.1.5/Makefile
-+++ aewm++-1.1.5/Makefile
-@@ -1,9 +1,6 @@
- CC = g++
+--- a/Makefile
++++ b/Makefile
+@@ -1,14 +1,9 @@
+-CC = g++
-ADDITIONAL_CFLAGS = -g -O2 -march=i686 -Wall
-
+-
prefix = /usr
-INCLUDES = -I$/usr/X11R6
-LDPATH = -L/usr/X11R6/lib
- LIBS = -lXext -lX11
+-LIBS = -lXext -lX11
++LIBS += -lXext -lX11
# SHAPE = Shape Extension
-@@ -28,14 +25,13 @@
+ # NEED_SETENV = Does your Unix not support the setenv function? Use this!
+-DEFINES = -DSHAPE #-DNEED_SETENV
++CPPFLAGS += -DSHAPE #-DNEED_SETENV
+ HEADERS = aewm.hh \
+ client.hh \
+ windowmanager.hh \
+@@ -28,14 +23,10 @@
all: aewm++
aewm++: $(OBJS)
- $(CC) $(OBJS) $(LDPATH) $(LIBS) -o $@
-+ $(CXX) $(LDFLAGS) $(OBJS) $(LDPATH) $(LIBS) -o $@
-
- $(OBJS): %.o: %.cc $(HEADERS)
+-
+-$(OBJS): %.o: %.cc $(HEADERS)
- $(CC) $(CFLAGS) $(ADDITIONAL_CFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
-+ $(CXX) $(CXXFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) $(OBJS) $(LIBS) -o $@
install: all
- mkdir -p $(DESTDIR)$(prefix)/bin