summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-05-17 16:10:15 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-05-17 16:12:36 +0200
commitf45b768bd5df758b38c50b5119576bab7a5ea4c2 (patch)
tree890e0856d13d3d2ffe6e8102ab90fc08b668fe68
parentdev-python/superqt: add 0.6.6 (diff)
downloadgentoo-f45b768bd5df758b38c50b5119576bab7a5ea4c2.tar.gz
gentoo-f45b768bd5df758b38c50b5119576bab7a5ea4c2.tar.bz2
gentoo-f45b768bd5df758b38c50b5119576bab7a5ea4c2.zip
dev-python/mkdocs-git-authors-plugin: add 0.9.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/mkdocs-git-authors-plugin/Manifest1
-rw-r--r--dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.9.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/mkdocs-git-authors-plugin/Manifest b/dev-python/mkdocs-git-authors-plugin/Manifest
index 3ae464b8c786..2017b4996a4f 100644
--- a/dev-python/mkdocs-git-authors-plugin/Manifest
+++ b/dev-python/mkdocs-git-authors-plugin/Manifest
@@ -1 +1,2 @@
DIST mkdocs-git-authors-plugin-0.8.0.gh.tar.gz 30080 BLAKE2B 08c0eee392ef94caf30f176f5c8923b4e3c5d951a36348bbeec4396052ee492715b99aa4f8824348728296e5276747083340943bd21f7850abd0ccfb3a2bf12c SHA512 4620c8cccf69eb8ec3010ac7483a3df1ab43bcf8e0837399f46383d9947fdddc0c70d7d8405c820f1cb4b773724ca7006f2cc3bdd5559c107a2db8e3ceb8b38e
+DIST mkdocs-git-authors-plugin-0.9.0.gh.tar.gz 30785 BLAKE2B babf9c6b200ee3ea6839e4b35c78e83c727477b9dbaee027fda49500d7b8bb57ffea2d960a2ca979ee8cb2e499a004dc49ca417c4a96054dad27408e4bbb0607 SHA512 66527124217eecef80025517b1fabe9b81c3b65808f0c32610a8333ace2bec1dbb316ad35aec819c03482e9a09961f8cf84f8b1c2f5bdfbd5e270c07019f06e6
diff --git a/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.9.0.ebuild b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.9.0.ebuild
new file mode 100644
index 000000000000..919c58515e2b
--- /dev/null
+++ b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.9.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..12} )
+
+# Requires self to be installed to build docs
+# TODO: Do this a bit better
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ dev-python/regex
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-authors-plugin
+"
+DOCS_INITIALIZE_GIT=1
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Mkdocs plugin to display git authors of a page"
+HOMEPAGE="
+ https://github.com/timvink/mkdocs-git-authors-plugin/
+ https://pypi.org/project/mkdocs-git-authors-plugin/
+"
+SRC_URI="https://github.com/timvink/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+# Tests are broken outside of upstream git repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocs-git-revision-date-localized-plugin[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-authors tests need git repo
+ use test && initialize_git_repo
+
+ distutils-r1_python_prepare_all
+}