summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@protonmail.com>2022-12-13 15:59:40 -0600
committerSam James <sam@gentoo.org>2023-01-04 05:31:57 +0000
commitf75639b635eacab161f65103ae4c53a3edffe816 (patch)
tree3110959ed750e9a2305bf14b1b7e21299c640647
parentdev-db/sqlmap: drop 1.6.10 (diff)
downloadgentoo-f75639b6.tar.gz
gentoo-f75639b6.tar.bz2
gentoo-f75639b6.zip
app-shells/bash: fix build with clang and USE=pgo
Signed-off-by: Leonardo Hernández Hernández <leohdz172@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/28659 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-shells/bash/bash-5.2_p15.ebuild2
-rw-r--r--app-shells/bash/bash-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/app-shells/bash/bash-5.2_p15.ebuild b/app-shells/bash/bash-5.2_p15.ebuild
index 3aa6795a6431..e0c1c5ecc52e 100644
--- a/app-shells/bash/bash-5.2_p15.ebuild
+++ b/app-shells/bash/bash-5.2_p15.ebuild
@@ -246,6 +246,8 @@ src_compile() {
emake CFLAGS="${CFLAGS} -fprofile-generate=${T}/pgo -fprofile-dir=${T}/pgo" -k check
+ tc-is-clang && llvm-profdata merge "${T}"/pgo --output="${T}"/pgo/default.profdata || die
+
# Rebuild Bash using the profiling data we just generated.
emake clean
emake CFLAGS="${CFLAGS} -fprofile-use=${T}/pgo -fprofile-dir=${T}/pgo"
diff --git a/app-shells/bash/bash-9999.ebuild b/app-shells/bash/bash-9999.ebuild
index 5fecc6b0353c..c082c658b1aa 100644
--- a/app-shells/bash/bash-9999.ebuild
+++ b/app-shells/bash/bash-9999.ebuild
@@ -246,6 +246,8 @@ src_compile() {
emake CFLAGS="${CFLAGS} -fprofile-generate=${T}/pgo -fprofile-dir=${T}/pgo" -k check
+ tc-is-clang && llvm-profdata merge "${T}"/pgo --output="${T}"/pgo/default.profdata || die
+
# Rebuild Bash using the profiling data we just generated.
emake clean
emake CFLAGS="${CFLAGS} -fprofile-use=${T}/pgo -fprofile-dir=${T}/pgo"