summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-24 15:31:50 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-24 15:35:20 +0100
commitf8110ceab3919bfff6ee2cc32a56771eb513eb67 (patch)
tree28291602fe8623ec71436090f150114886699c23
parentdev-ruby/instance_storage: add new package (diff)
downloadgentoo-f8110ceab3919bfff6ee2cc32a56771eb513eb67.tar.gz
gentoo-f8110ceab3919bfff6ee2cc32a56771eb513eb67.tar.bz2
gentoo-f8110ceab3919bfff6ee2cc32a56771eb513eb67.zip
net-analyzer/bwm-ng: Version bump to 0.6.1
Gentoo-Bug: 561718 * EAPI=6 * Fix ncurses underlinking issue Package-Manager: portage-2.2.27
-rw-r--r--net-analyzer/bwm-ng/Manifest1
-rw-r--r--net-analyzer/bwm-ng/bwm-ng-0.6.1.ebuild38
-rw-r--r--net-analyzer/bwm-ng/files/bwm-ng-0.6.1-fix-buildsystem.patch82
3 files changed, 121 insertions, 0 deletions
diff --git a/net-analyzer/bwm-ng/Manifest b/net-analyzer/bwm-ng/Manifest
index eb0a4d148c88..78ef7d57d1a4 100644
--- a/net-analyzer/bwm-ng/Manifest
+++ b/net-analyzer/bwm-ng/Manifest
@@ -1 +1,2 @@
+DIST bwm-ng-0.6.1.tar.gz 162620 SHA256 027cf3c960cd96fc9ffacdf7713df62d0fc55eeef4a1388289f8a62ae5e50df0 SHA512 3f8d4a10f5cbf743d6aee9c6170f334c4274224a2f1886f04338c9a1bf0cf13af5be4aaea0445c9e5b5d361915cc3a93bbfe7c4abf69a0d24e42bc414d8056cd WHIRLPOOL a83569acf0f4f24f98e5b65733e0a02de2db4a4249ece24eaf457b20a4eed4a6f425256a13477e8d3844c251b4818fc8b1e34243a975cce7e20ec27b3af8e413
DIST bwm-ng-0.6.tar.gz 141564 SHA256 c1134358e268329d438b0996399003b0f0b966034fb4b5b138761c2f3c62ffdd SHA512 7327ec848b0c18d68b2cb0a0ca570bb4d783b534186868d13b453346dbf3ddbcd7e1070803406ff207dc1fd00aa91c06187b0ea7fea28c6c006b44165331c21b WHIRLPOOL 45cc30b6a99ed9c267095e6dca170380be3da698e7b8aab50436d51ea914714facf954b9c26e465f47a1bcd59ca3fbd5511cd654b42fd9d4a5131e2f5bbca233
diff --git a/net-analyzer/bwm-ng/bwm-ng-0.6.1.ebuild b/net-analyzer/bwm-ng/bwm-ng-0.6.1.ebuild
new file mode 100644
index 000000000000..ae30fbd3d4f7
--- /dev/null
+++ b/net-analyzer/bwm-ng/bwm-ng-0.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Bandwidth Monitor NG is a small and simple console-based bandwidth monitor"
+SRC_URI="http://www.gropp.org/bwm-ng/${P}.tar.gz"
+HOMEPAGE="http://www.gropp.org/"
+
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="html csv"
+
+DEPEND="sys-libs/ncurses:0=
+ >=sys-apps/net-tools-1.60-r1"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-buildsystem.patch"
+)
+
+src_prepare() {
+ mv configure.{in,ac} || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-ncurses \
+ --with-procnetdev \
+ $(use_enable html) \
+ $(use_enable csv)
+}
diff --git a/net-analyzer/bwm-ng/files/bwm-ng-0.6.1-fix-buildsystem.patch b/net-analyzer/bwm-ng/files/bwm-ng-0.6.1-fix-buildsystem.patch
new file mode 100644
index 000000000000..85f2819786e2
--- /dev/null
+++ b/net-analyzer/bwm-ng/files/bwm-ng-0.6.1-fix-buildsystem.patch
@@ -0,0 +1,82 @@
+* Fix broken buildsystem
+* Fix ncurses underlinking caused by missing "-ltinfo" in $LIBS
+https://bugs.gentoo.org/show_bug.cgi?id=561718
+
+--- bwm-ng-0.6.1/configure.ac
++++ bwm-ng-0.6.1/configure.ac
+@@ -3,7 +3,7 @@
+
+ AC_INIT([bwm-ng],[0.6.1],[bwmng@gropp.org],[bwm-ng])
+ AC_CONFIG_SRCDIR(src/bwm-ng.c)
+-AM_INIT_AUTOMAKE([gnu])
++AM_INIT_AUTOMAKE([gnu subdir-objects])
+ AC_CONFIG_HEADERS(config.h)
+ AC_CONFIG_MACRO_DIR(./)
+ AC_LANG([C])
+@@ -28,44 +28,12 @@
+ AC_CHECK_TYPES(unsigned long long)
+
+ # Checks for libraries.
+-CURSES_CHECKED="0"
++AC_ARG_ENABLE([ncurses],
++ AS_HELP_STRING([--enable-ncurses], [Enable feature ncurses]))
+
+-AC_ARG_WITH([curses],AS_HELP_STRING([--with-curses],[with curses (ARG=PATH)]),[
+-if [ test $withval != "no" ]; then
+- OLD_CPPFLAGS=$CPPFLAGS
+- if [ test $withval != "yes" ]; then
+- CPPFLAGS="$CPPFLAGS -I$withval"
+- fi
+- AC_CHECK_LIB([curses],[newterm,timeout],,[ CPPFLAGS=$OLD_CPPFLAGS ])
+- CURSES_CHECKED="1"
+-else
+- CURSES_CHECKED="1"
+-fi
+-])
+-
+-
+-if [ test $CURSES_CHECKED != "1" ]; then
+-AC_ARG_WITH([ncurses],AS_HELP_STRING([--with-ncurses],[prefer ncurses over curses (ARG=PATH)]),[
+-if [ test $withval != "no" ]; then
+- OLD_CPPFLAGS=$CPPFLAGS
+- if [ test $withval != "yes" ]; then
+- CPPFLAGS="$CPPFLAGS -I$withval"
+- fi
+- AC_CHECK_LIB([ncurses],[newterm,timeout],,[ CPPFLAGS=$OLD_CPPFLAGS ])
+- CURSES_CHECKED="1"
+-else
+- CURSES_CHECKED="1"
+-fi
++AS_IF([test "x$enable_ncurses" != "xno"], [
++ PKG_CHECK_MODULES([NCURSES], [ncurses])
+ ])
+-fi
+-
+-
+-
+-if [ test $CURSES_CHECKED != "1" ]; then
+-AC_CHECK_LIB([curses],[initscr,timeout],,[
+- AC_CHECK_LIB([ncurses],[newterm,timeout])
+-])
+-fi
+
+ AC_CHECK_FUNCS([wattron])
+ AC_CHECK_FUNCS([curs_set])
+--- bwm-ng-0.6.1/src/Makefile.am
++++ bwm-ng-0.6.1/src/Makefile.am
+@@ -2,12 +2,10 @@
+
+ bin_PROGRAMS = bwm-ng
+
+-bwm_ng_SOURCES = bwm-ng.c process.c output.c options.c help.c curses_tools.c
++bwm_ng_SOURCES = bwm-ng.c process.c output.c options.c help.c curses_tools.c input/retrieve.c input/devstat.c input/libkstat.c input/netstat.c input/proc_net_dev.c input/sysctl.c input/ioservice.c input/libstatgrab.c input/proc_diskstats.c input/win32.c input/getifaddrs.c
+
+-EXTRA_bwm_ng_SOURCES = input/retrieve.c input/devstat.c input/libkstat.c input/netstat.c input/proc_net_dev.c input/sysctl.c input/ioservice.c input/libstatgrab.c input/proc_diskstats.c input/win32.c input/getifaddrs.c
+-
+-bwm_ng_LDADD = retrieve.$(OBJEXT) $(INPUT_SYSTEM)
+-bwm_ng_DEPENDENCIES = retrieve.$(OBJEXT) $(INPUT_SYSTEM)
++bwm_ng_CPPFLAGS = @NCURSES_CFLAGS@
++bwm_ng_LDADD = @NCURSES_LIBS@
+
+ noinst_HEADERS = bwm-ng.h process.h output.h options.h help.h curses_tools.h types.h defines.h global_vars.h input/devstat.h input/libkstat.h input/netstat.h input/proc_net_dev.h input/sysctl.h input/ioservice.h input/libstatgrab.h input/proc_diskstats.h input/retrieve.h input/win32.h input/getifaddrs.h
+