summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-03-24 23:07:32 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-03-24 23:09:08 +0100
commitf92a659da835aea056c791d2c8e2d3e38b50a5d4 (patch)
treea349bed043efcb0ecf776b32cd8ce518a2143618
parentdev-perl/Bio-DB-HTS: respect LDFLAGS (diff)
downloadgentoo-f92a659da835aea056c791d2c8e2d3e38b50a5d4.tar.gz
gentoo-f92a659da835aea056c791d2c8e2d3e38b50a5d4.tar.bz2
gentoo-f92a659da835aea056c791d2c8e2d3e38b50a5d4.zip
sys-libs/libutempter: EAPI-7 revbump
Package-Manager: Portage-2.3.95, Repoman-2.3.21 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-libs/libutempter/libutempter-1.1.6-r3.ebuild (renamed from sys-libs/libutempter/libutempter-1.1.6-r2.ebuild)19
1 files changed, 10 insertions, 9 deletions
diff --git a/sys-libs/libutempter/libutempter-1.1.6-r2.ebuild b/sys-libs/libutempter/libutempter-1.1.6-r3.ebuild
index 4b54fc4cef3e..00420c6927b6 100644
--- a/sys-libs/libutempter/libutempter-1.1.6-r2.ebuild
+++ b/sys-libs/libutempter/libutempter-1.1.6-r3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit user multilib flag-o-matic toolchain-funcs
+inherit multilib flag-o-matic toolchain-funcs
DESCRIPTION="Library that allows non-privileged apps to write utmp (login) info"
HOMEPAGE="https://altlinux.org/index.php?module=sisyphus&package=libutempter"
@@ -14,13 +14,14 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
IUSE="static-libs elibc_FreeBSD"
-RDEPEND="!sys-apps/utempter"
-
-pkg_setup() {
- enewgroup utmp 406
-}
+RDEPEND="
+ !sys-apps/utempter
+ acct-group/utmp
+"
src_prepare() {
+ default
+
local args=(
-e "/^libdir /s:/usr/lib:${EPREFIX}/usr/$(get_libdir):"
-e '/^libexecdir /s:=.*:= $(libdir)/misc:'
@@ -57,12 +58,12 @@ src_install() {
}
pkg_postinst() {
- if [ -f "${EROOT}/var/log/wtmp" ] ; then
+ if [[ -f "${EROOT}/var/log/wtmp" ]] ; then
chown root:utmp "${EROOT}/var/log/wtmp"
chmod 664 "${EROOT}/var/log/wtmp"
fi
- if [ -f "${EROOT}/var/run/utmp" ] ; then
+ if [[ -f "${EROOT}/var/run/utmp" ]] ; then
chown root:utmp "${EROOT}/var/run/utmp"
chmod 664 "${EROOT}/var/run/utmp"
fi