summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-24 21:40:11 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-24 22:12:56 +0200
commitf9fabc59b0c9c193d38579876263652fcc297be0 (patch)
tree2956738b58977d784e102556d63027594de62f93
parentdev-python/nose_fixes: Enable py3.{7,8}, modernize (diff)
downloadgentoo-f9fabc59b0c9c193d38579876263652fcc297be0.tar.gz
gentoo-f9fabc59b0c9c193d38579876263652fcc297be0.tar.bz2
gentoo-f9fabc59b0c9c193d38579876263652fcc297be0.zip
dev-python/ntplib: Enable py3.{7,8}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ntplib/ntplib-0.3.3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/ntplib/ntplib-0.3.3.ebuild b/dev-python/ntplib/ntplib-0.3.3.ebuild
index 37e5fcbc114c..11967a49ea26 100644
--- a/dev-python/ntplib/ntplib-0.3.3.ebuild
+++ b/dev-python/ntplib/ntplib-0.3.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -18,5 +18,5 @@ IUSE=""
RESTRICT="test"
python_test() {
- "${PYTHON:-python}" ./test_ntplib.py
+ "${EPYTHON}" ./test_ntplib.py || die
}