summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-05-02 11:24:43 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-02 13:16:38 +0200
commitfb29558a5a999d861c5cfea5ba18d94020b8ef0b (patch)
treead16e96fde7282f7843c786ac2c7b47e8ab03d10
parentnet-analyzer/gvm-libs: add 21.4.4 (diff)
downloadgentoo-fb29558a.tar.gz
gentoo-fb29558a.tar.bz2
gentoo-fb29558a.zip
net-analyzer/python-gvm: add 21.11.0
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--net-analyzer/python-gvm/Manifest1
-rw-r--r--net-analyzer/python-gvm/python-gvm-21.11.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/python-gvm/Manifest b/net-analyzer/python-gvm/Manifest
index bc9ede7565f3..ccb8777ca0d0 100644
--- a/net-analyzer/python-gvm/Manifest
+++ b/net-analyzer/python-gvm/Manifest
@@ -1 +1,2 @@
DIST python-gvm-21.1.3.tar.gz 244785 BLAKE2B 7f0a63651a01a914359ea683cf52fe2e1ced22aba0bb90d232c4e5a13f25bb0a9d76a647c2bbe34f0be9615c0ce4d7fb938eee3fbe3a2389b7483b4d55069fee SHA512 eb92be77e69303e0ece54efb5bceaefb469ab1c3f4a2714ec1c839d43584e5760618c39a133aaaeb436c9f62d6deec8f40608e792f408e8cae7c083db857183f
+DIST python-gvm-21.11.0.tar.gz 230324 BLAKE2B 1c4ca09f62dbeb6863e6f2da7188fd499d38ec9e1c01a2cac3534b2bff996082a5075a437e225a51bbb98f7a6ebc67062f5bd31ac1ce1a831a82bcc85f377a62 SHA512 df1fe64c65453a782dd89615cb6426a47091c82899d73855ec14174ea01ca3066a987eacb4f553c575695c6a962ec635023d0b79eafe143b564e4dfe494cc2a9
diff --git a/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild b/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild
new file mode 100644
index 000000000000..b50a5c454cd0
--- /dev/null
+++ b/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
+
+DESCRIPTION="Greenbone Vulnerability Management Python Library"
+HOMEPAGE="https://www.greenbone.net/en/ https://github.com/greenbone/python-gvm/"
+SRC_URI="https://github.com/greenbone/python-gvm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest