summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-02 17:31:35 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-02 17:32:43 +0100
commitfe9fa7c79fa9cb1d9d28f5d5ddbc72cc9e7e4b6f (patch)
tree4a0ddc05aadb4ea380e9c07b8a90b902b1aef2c0
parentapp-emacs/org-mode: drop old 9.6.14 (diff)
downloadgentoo-fe9fa7c79fa9cb1d9d28f5d5ddbc72cc9e7e4b6f.tar.gz
gentoo-fe9fa7c79fa9cb1d9d28f5d5ddbc72cc9e7e4b6f.tar.bz2
gentoo-fe9fa7c79fa9cb1d9d28f5d5ddbc72cc9e7e4b6f.zip
app-emacs/crux: bump to 0.5.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/crux/Manifest1
-rw-r--r--app-emacs/crux/crux-0.5.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/crux/Manifest b/app-emacs/crux/Manifest
index 7aed82f443dd..ccee985f8af7 100644
--- a/app-emacs/crux/Manifest
+++ b/app-emacs/crux/Manifest
@@ -1 +1,2 @@
DIST crux-0.4.0.tar.gz 12611 BLAKE2B aa5655b703c81db3cd212caba0027873ccfe42e5b22e7534285d36b9eb9fc17178ee5d2b6500feb281f0fb82c18e599e7769d0a6647f75825695ea8eb5aba5c9 SHA512 d961d7f41a184c8521e4cd27e262feda4516807d3157e8ea79bc67086fe65d70be60673246bf3114ddaa50d25caa2622c85a62742e3cd230e5fe69a224ecfa5d
+DIST crux-0.5.0.tar.gz 13100 BLAKE2B dfbe1eb196c5fa0420cba55f726c31bf9144fb312b88dc9414079cb9357e79e0e0ffc23fd25929c2d1e8573e50be617e169f7eb2ff99daaff3df98ef5f4536f6 SHA512 047f40c4a6ca8ad415923809890c957a8746a6bb92e78e161a3403a5e87a2af27c013fe4684a9c1315b4bbcaa29903ac1d8c3e7b50aa82a527ebdcfb1e910274
diff --git a/app-emacs/crux/crux-0.5.0.ebuild b/app-emacs/crux/crux-0.5.0.ebuild
new file mode 100644
index 000000000000..dcc16069ffc5
--- /dev/null
+++ b/app-emacs/crux/crux-0.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Collection of Ridiculously Useful eXtensions for GNU Emacs"
+HOMEPAGE="https://github.com/bbatsov/crux/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/bbatsov/${PN}.git"
+else
+ SRC_URI="https://github.com/bbatsov/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}